Author Topic: Error using Preprocessing Script  (Read 1784 times)

Offline tloebl

  • PixInsight Addict
  • ***
  • Posts: 135
    • View Profile
Error using Preprocessing Script
« on: 2015 February 14 06:42:03 »
Hi,

using the preprocessing script, I choose my master flat, master bias, master dark, and my luminance frames. When I choose DIAGNOSTICS or RUN, I get the following error:

 ** Warning: No flat frames have been selected to calibrate light frames (filter="Clear", binning=1, exposure=120.00s, length=59). I am using FIT or FITS extensions on all my files.

Has anyone had similar issues?

Tom

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4543
    • View Profile
Re: Error using Preprocessing Script
« Reply #1 on: 2015 February 14 11:41:39 »
the script attempts to automatically match flats with your different filters. the warning means it has failed to do this. there may be a mismatch in the FITS header filter names in the lights vs. the master flat. was the master flat created with BPP?

rob

Offline tloebl

  • PixInsight Addict
  • ***
  • Posts: 135
    • View Profile
Re: Error using Preprocessing Script
« Reply #2 on: 2015 February 15 15:28:45 »
The flats were created by stacking a series of 16 fits images in PI  from SBIG files generated using CCDops. I used FITSConvert to convert from SBIG format. I am not familiar with BPP, could you elaborate? Should I be editing the FITS headers?

Thanks,
Tom

Offline tloebl

  • PixInsight Addict
  • ***
  • Posts: 135
    • View Profile
Re: Error using Preprocessing Script
« Reply #3 on: 2015 February 15 16:08:18 »
Rob,

I created the master flat using the image integration tool not the BPP script....

Tom

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4543
    • View Profile
Re: Error using Preprocessing Script
« Reply #4 on: 2015 February 15 17:46:11 »
i am not sure if II will preserve the fits header from the original input files.

it sounds to me like you'll have to add the master flat as a custom frame and use the same filter name that the lights have in their FITS header...

or as you say you can edit the FITS header of the master flat to add the filter name keyword and value.

rob

Offline tloebl

  • PixInsight Addict
  • ***
  • Posts: 135
    • View Profile
Re: Error using Preprocessing Script
« Reply #5 on: 2015 February 16 16:34:38 »

It doesn't look like my flats are being processed by the pre-processor script. I added a FLAT parameter into the fits header but I still get the  "Warning: No flat frames have been selected to calibrate light frames"  when running the script. I also get a "** Warning: No correlation between the master dark and target frames (channel 0)" though the dark is being subtracted. Sounds like this might also be due to there being no DARK parameter in the fits header. Is there a tutorial for what PI requires in the fits header? Seems like a chore having to modify the fits headers.

Tom