PixInsight running well in WSL - CUDA next?


Well-known member

Having recently upgraded my OS to Win11, I was keen to test the Windows Subsystem for Linux (WSL) version 2 with GUI.


I am no programmer and can basically follow instructions online. I have a few Raspberry Pis scattered around the house and in the observatory so am fairly familiar with getting things done from the command line. I chose Ubuntu 20.04 LTS for my WSL installation and I have to say I was very impressed with how simple it was to get it running. I have had other Linux flavours running in Oracle VirtualBox but this is simpler and faster.

Following the instructions to install PixInsight in Linux was fine but when I tried to run it, it failed to launch complaining it was missing plugins from the Qt platform. Following the instructions at the bottom of this post fixed it: https://pixinsight.com/forum/index....-plugin-repost-from-general.15197/post-107954

PixInsight launches nicely and it's faster than my equivalent installation in Windows:



Anyone installed PixInsight in WSL yet? Anyone interested in trying to get tensorflow and CUDA to play ball?

Both. To test WSL with a more complex application such as PixInsight and because the latter runs so much faster in Linux.
Thank you for the instructions. I was able to follow along and got PI working, however after running the benchmark I received no performance benefit.