PixInsight 1.8.3 Ripley: New Mac OS X Distribution

Perhaps this will save someone else a couple of hours. Some users of PixInsight may have a minimal understanding of command lines and a few may have none. Mine is pretty minimal and very rusty.

I tried several times to install PI-macosx-x86_64- on OS X 10.9.3 Mavericks, sometimes by extracting it in Zipeg and saving the extraction files into /Applications, other times by saving the zip file first to the Downloads folder and then extracting, or by saving to /Applications and then extracting. I tried rebooting after extracting and waiting overnight to ensure that the download completes. The result was always the same, a small window with the message:

?The Pixinsight Core application has been launched from a directory that does not meet the requirements of a valid PixInsight distribution.?

I noticed that Gerry Doyle in Reply #18 on this thread said: ?I'd used a 'Zipeg' app to unzip the download - this time round I used the embedded OS X utility and it unzipped properly.? I noticed that J.C. supported this method. I didn?t know what utility Gerry was referring to. The only relevant one that appears in my utilities folder is Zipeg. So I guessed he must have referred to the unix utility unzip or maybe zcat. Following an OS X manual, I opened the terminal program and tried zcat and failed to get results. I browsed online and found a recommendation to type ?unzip? into the terminal and then drag the .zip file to the terminal window, drop it on the line, and hit return. This produced the desired results. I located the new PixInsight folder, dragged it to Applications, dropped it in, and as I type this, fifteen upgrades are downloading from within PixInsight.
Hi Gary,

I don't understand why OS X users insist in using applications such as zipeg to decompress .zip files. ZIP compression/decompression is supported natively by the OS X operating system. To uncompress a PixInsight distribution package on OS X, simply double click it. It works perfectly; nothing else is necessary.

I guess we persist in using Zipeg because we weren't aware of another way. I was still not aware of it until your most recent reply. Zipeg comes with the OS, so double clicking on the zip file brings up Zipeg. Those of us who don't spend much time researching how our OS works have been conditioned to believe that is the natural order of things, but apparently it is just a form of product placement. Thanks for the information. I will dump the Zipeg.
?? Zipeg does not come with OSX. apple has their own unzip utility. when you double click a .zip file, by default OSX runs the application in /System/Library/CoreServices/Archive\ Utility.app .

apple is one of the few companies that does not install any, and i mean any, 3rd party software on their computers or mobile phones. so no product placement... you must have installed Zipeg at some point, and then it took over the ".zip" file extension in Finder.app.

Sorry if this has nothing to do with this particular thread, but since the last update I have lost my work spaces along the bottom and have no stretch functions across the top, no preview selections either?

Another silly Mac user...
@Rob/pfile, no dispute, but some puzzlement as to why I might have installed it, since the Apple unzip works so well.
I just downloaded the trial version of PixInsight for Mac OS X.  I'm using Sierra on an iMac, commercial OS version which came out today.  I'm getting the dread message:  'The PixInsight Core Application has been launched from a directory that does not meet the requirements of a valid PixInsight distribution.  Either the PixInsight executable has been moved or the distribution has been damaged for some reason.  PixInsight cannot be executed. Please reinstall the application.'

Have tried re-downloading, and all the suggestions (Terminal, etc.) in the forum, to no avail.  What's curious is: since it didn't seem to work on my iMac, I tried installing it on my MacBook Air.  It works fine on the laptop.  But where I want it is my iMac, and I can't get it to work there.  Please help!

-stan in Brooklyn
this is probably due to a new feature in sierra: although you store your applications in /Applications, when they get executed, they are executed in another (random) directory. this prevents malware from trying to modify files in the application bundle, as there's no way to guess what the randomized pathname is.

there's a little bit of info in this article, midway down the page.


notably if the application existed prior to the upgrade to sierra, it looks like it still works the old way. but installing PI from scratch on sierra results in the directory randomization.

i'm afraid juan is going to have to make changes to the way PI works to support sierra...

Rob has nailed it. The current version 1.8.4 of PixInsight does not work on macOS 10.12 Sierra precisely because GPR (Gatekeeper Path Randomization) changes the installation path dynamically, which does not allow the PixInsight Core application to find any installed modules, scripts and support files.

I am trying to get this problem fixed as soon as possible with a new version for OS X, but please understand that the solution is not easy. I have to make deep changes to the application's distribution, including the update system. For now, we don't support macOS 10.12, so you'll have to stick with OS X 10.11 until the next release is ready.
I have a new version of the core application almost ready, which should work without problems on macOS 10.12 Sierra. However, I need some users to test it on their machines before an official release. Any volunteers?
Hi Juan, I just installed a new hard drive with a fresh installation of 10.12 today and came to this thread after I couldn't get PixInsight working.  I'd be happy to test out the beta version you've cooked up.
Ok.  I connected my old hard disk via an external enclosure and PixInsight was able to run in my new installation from the external drive.  Next I copied the PixInsight application folder to the application folder on my new disk and now it's working just fine.  Still running 10.12 and willing to help test out the new version if needed.  Let me know.
Juan Conejero said:
I have a new version of the core application almost ready, which should work without problems on macOS 10.12 Sierra. However, I need some users to test it on their machines before an official release. Any volunteers?


I want to test. On my macOS PI crashed every 15-20 minutes.
Version for Mac is now available on the software distribution server (commercial and trial versions). It should work without problems on macOS 10.12 Sierra, and works perfectly on OS X 10.10 and 10.11.

Besides being a new version, slightly more stable and efficient than, build 1199 *requires* to be installed on the standard /Applications folder. Previous versions could be deployed anywhere on the local filesystem. This flexibility is now lost forever since macOS 10.12. Note however, that you can uncompress the distribution .zip file on /Applications and then copy or move the PixInsight.app application bundle anywhere. As long as the original PixInsight distribution folder is on /Applications, the application bundle can now be launched from any arbitrary location.

This is a temporary version to keep PixInsight running on newly installed macOS 10.12 machines. There will be a new release in October with new functionality and improved compatibility with current operating system versions.

Let me know if this version works on new macOS 10.12 installations. Based on your positive feedback, I'll make an official announcement. Thank you for testing.
I have been using PI for the last 3 years on a Mac through various OS versions.

I upgraded to this morning - all installed correctly.

I then upgraded to OS Sierra (from Yosemite) and PI appears to be working correctly.