Author Topic: New script for denoising linear monochannel images  (Read 37727 times)

Offline eganz

  • Member
  • *
  • Posts: 50
    • View Profile
    • Eric Ganz Flickr
Re: New script for denoising linear monochannel images
« Reply #135 on: 2017 March 01 13:55:44 »
Mike,

I was enjoying the new gradient/noise thresholds parameter method, and it was improving the results for my images.
However, now in the latest version 1.21, this functionality has disappeared.

What's up?

Eric

Offline Buzz

  • PixInsight Enthusiast
  • **
  • Posts: 77
    • View Profile
    • The Astrophotography Manual - support
Re: New script for denoising linear monochannel images
« Reply #136 on: 2017 March 04 08:13:49 »
I have been having fantastic success with MUREDenoise on my images.  I tried it today and it is repeatedly creating a regular noise pattern on the images. Has something recently changed in the base algorithm? I need to open an old project and see if, indeed, something has changed.
regards
Chris

Offline mschuster

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1001
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #137 on: 2017 March 04 16:27:28 »
Eric, sorry, I found a gradient/noise classifier problem, the option is removed until I find a solution. Within a pixel or two of a sharp, high contrast edge (more common in natural images) denoising tends to be a bit too conservative.

Chris, yes changes (runs faster, less roundoff error, better cycle-spin effectiveness), but should be nothing that introduces this problem. Typical cause is incorrect script parameter values. Can you provide the image in dropbox, along with parameter values? I will run the previous versions for comparison.

Thank you,
Mike
« Last Edit: 2017 March 04 22:55:55 by mschuster »

Offline Saad

  • Newcomer
  • Posts: 1
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #138 on: 2018 February 20 09:16:04 »
Hello,

I am trying out the Mure Denoise camera for my images. I use a SBIG ST8300M for narrowband imaging (30 min subs) at -15C and 0C in summers.

I have computed a gain of 0.371e- and a gaussian noise of 29.52 DN. However, the result of DEMURE seems to produce blotches in the image. It is not as smooth as it is for others in this thread. What can I do to improve this?




Offline mschuster

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1001
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #139 on: 2018 February 20 13:30:24 »
"Smoothness" is somewhat subjective and also somewhat a function of how much you stretch.

Your detector gain and noise values seem reasonable for unbinned 8300.

A couple things to try:

Double check the Image Combination count and Interpolation method settings. Incorrect values cause trouble.

Double check the Detector Offset setting. The default 0 is appropriate only for calibrated images (bias and/or dark subtracted). If the image has not been bias/dark subtracted, then a non-zero value must be used. The DarkBiasNoiseEstimator script can provide an estimate (when run on a bias or dark frame).

Try reducing the Variance scale value from default 1 to 0.9 or less. A value less than 1 will reduce the amount of denoising.

Offline troypiggo

  • PixInsight Addict
  • ***
  • Posts: 257
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #140 on: 2018 June 02 16:07:03 »
I notice that the number of interpolation algorithms in the script's drop-down do not match all of the options that star alignment.  eg Bicubic spline is available, but SA has bicubic spline and bicubic b-spline and so on.  I've been using b-spline is SA.  Results using just bicubic spline as closest match in Mure Denoise appear ok.  Just curious if that's right, or should we limit use of SA algorithms to match the options in MureDN?

Offline mschuster

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1001
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #141 on: 2018 June 02 21:16:31 »
Troy, what you are doing is fine. When using any of the missing methods, check for excessive denoising artifacts (eg, pixel checker-boarding) and reduce Variance Scale slightly if you see problems. Sorry for the lack of support, I didn't spend the necessary development time thinking that these other methods were not often used.

Offline troypiggo

  • PixInsight Addict
  • ***
  • Posts: 257
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #142 on: 2018 June 03 03:37:51 »
Thanks mate.

Offline mschuster

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1001
    • View Profile
Re: New script for denoising linear monochannel images
« Reply #143 on: 2019 February 12 15:13:43 »
MureDenoise 1.22 release, should appear as an auto-update soon.

When you apply several processes to a preview, the preview's base image is normally used as input to each process. The results from previous processes are normally discarded, unless you use the command Preview > Store.

Up until this new release, MureDenoise did not work this way. If you applied MureDenoise multiple times to a preview (say to test different parameter settings) previous results were not discarded and you ended up denoising a previously denoised result, a bad thing to do. The new release fixes this problem. Thank you ngc1535 very much for finding and reporting this bug.

Also, the new release has updated documentation and tooltips for several of the script's parameters. This should help with ease of use.

 

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6480
    • View Profile
    • http://pixinsight.com/
Re: New script for denoising linear monochannel images
« Reply #144 on: 2019 February 14 01:54:38 »
I have just released the corresponding updates for MureDenoise 1.22 and its documentation.

Mike, thank you so much for your continued excellent work. Thank you also Adam for your help and support.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/