Author Topic: Images rotate 90 degrees when copying from another hard drive  (Read 3035 times)

Offline alcol

  • Member
  • *
  • Posts: 63
    • View Profile
Hi folks

Not sure what is happening but.

I have taken light images and have them stored on my laptop. They are orientated in landscape and show up as 5202x3465 pixels.

I transfer the Lights to my desktop for processing on PI and for some reason they get rotated through 90 degrees and appear as 3465x5202 pixels. When i try to calibrate with darks etc I get an incompatible geometry error message. 

Help urgently required

Thanks

Alec

Offline NGC7789

  • PixInsight Old Hand
  • ****
  • Posts: 391
    • View Profile
I would check your file type settings (you don't mention what type of files these are). There is probably a setting causing this rotation.

You can also rotate them back with the rotation tool. You can apply it to all the affected images with an image container.

Offline alcol

  • Member
  • *
  • Posts: 63
    • View Profile
They are the cr2 raw files from the 550d DSLR.

I can see where to rotate individual images, where is the tool to rotate and save all of them in 1 go?

Thanks




Offline Carlos Milovic

  • PTeam Member
  • PixInsight Jedi Master
  • ******
  • Posts: 2169
  • Join the dark side... we have cookies
    • View Profile
    • http://www.astrophoto.cl
You'll have to create an image container, and drop the Rotation instance over there.
Regards,

Carlos Milovic F.
--------------------------------
PixInsight Project Developer
http://www.pixinsight.com

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 3777
    • View Profile
something is wrong here - CR2 files are never stored by the camera in a rotated format. if you have the setting turned on in your camera and you are holding the camera rotated while taking a picture, a flag is written to the file's EXIF structure that indicates that the camera was rotated. display software is supposed to recognize this flag and display the image rotated. but the sensor data is always recorded with the long axis being the X axis.

the rotation flag has little use in astrophotography, and i'm pretty sure that PI ignores it. are you sure you aren't trying to combine CR2 and TIFF images? if you open a CR2 with a program that recognizes the flag and then save it out as TIFF or JPEG, it's possible that the rotation will be "baked in" to the TIFF/JPEG.

rob

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6115
    • View Profile
    • http://pixinsight.com/
Select the no image flip option in RAW Format Preferences:

http://pixinsight.com/forum/index.php?topic=8226.0

or click the "Pure Raw" button to load the raw data.

Alternatively, if you are calibrating your data manually, you can (should, really) specify the "raw cfa" input format hints in the ImageCalibration tool. If you are using the BatchPreprocessing script to calibrate (recommended), then you don't have to care about this.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline alcol

  • Member
  • *
  • Posts: 63
    • View Profile
Hi

When I check the Raw files on the laptop where the images are downloaded from the DSLR they all look to be in the landscape layout, no hint of anything rotated. It is only when I copy the files over to my Desktop, where PI is installed, that SOME of the images get rotated. I notice that only 4 images stay in landscape format and the others get rotated.

I will check the settings and report back.

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 3777
    • View Profile
the reason some of them are rotated and some are not is that at some point while the telescope was tracking the camera started interpreting it's position as "rotated 90 degrees". it does not make sense that simply copying them would cause this. are you looking at them with different software before you copy them?

at any rate juan's advise is correct - you want PI to completely ignore the rotation flags in the CR2 metadata.

rob

Offline alcol

  • Member
  • *
  • Posts: 63
    • View Profile
Thanks everyone, much appreciated.

The simple phrase "raw cfa" in the  input format hints has cured all the problems. (No idea how, but I will leave that to cleverer people than me...)

Thanks again.

Alec