Author Topic: CurvesTransformation: CIE a* and CIE c* don't play well together  (Read 864 times)

Offline David Serrano

  • PTeam Member
  • PixInsight Guru
  • ****
  • Posts: 503
    • View Profile
In CurvesTransformation, CIE c* doesn't seem to be transformed when CIE a* is also touched. However, if a* is reset and we edit b* instead, then c* is honoured. This alone is why I'm posting under "Bug reports".

Code: [Select]
var P = new CurvesTransformation;
P.R = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.Rt = CurvesTransformation.prototype.AkimaSubsplines;
P.G = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.Gt = CurvesTransformation.prototype.AkimaSubsplines;
P.B = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.Bt = CurvesTransformation.prototype.AkimaSubsplines;
P.K = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.Kt = CurvesTransformation.prototype.AkimaSubsplines;
P.L = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.Lt = CurvesTransformation.prototype.AkimaSubsplines;
P.a = [ // x, y
   [0.00000, 0.00000],
   [0.48930, 0.52941],
   [1.00000, 1.00000]
];
P.at = CurvesTransformation.prototype.AkimaSubsplines;
P.b = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.bt = CurvesTransformation.prototype.AkimaSubsplines;
P.c = [ // x, y
   [0.00000, 0.00000],
   [0.03743, 0.42513],
   [1.00000, 1.00000]
];
P.ct = CurvesTransformation.prototype.AkimaSubsplines;
P.H = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.Ht = CurvesTransformation.prototype.AkimaSubsplines;
P.S = [ // x, y
   [0.00000, 0.00000],
   [1.00000, 1.00000]
];
P.St = CurvesTransformation.prototype.AkimaSubsplines;

To reproduce: open an image, open CT, edit its source code, paste that, apply to the image. What this does is alter CIE a* a bit, and do an obvious modification to CIE c*. However, c* is, in this computer at this moment, ignored. (edit: Real-Time Preview works as expected)

To rule out the possibility of being bitten by a memory corruption that might have happened elsewhere during the previous 2 hours of PixInsight'ing, I restarted the program—however I could immediately reproduce this. Can anyone else try, please?
« Last Edit: 2015 May 05 13:50:56 by David Serrano »
--
 David Serrano