Author Topic: Image integration issues  (Read 2609 times)

Offline David Bennett

  • Newcomer
  • Posts: 3
    • View Profile
Image integration issues
« on: 2014 March 20 08:41:26 »
Greetings.  Using the latest version of PixInsight (PixInsight Core 01.08.01.1087 Ripley (x64)) I am having issues with the software crashing during image integration.  I am on a 64bit Mac Pro OS X 10.8.5 with 64GB RAM and 24 logical processors.  I am trying to integrate about 250 single shot color images that have already been calibrated and registered with PixInsight. I have tried adjusting the buffer and stack size but this didn't work.  Any suggestions?  I have only been integrate less than 200 images before crashing.  Thanks in advance.

Dave

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 7096
    • View Profile
    • http://pixinsight.com/
Re: Image integration issues
« Reply #1 on: 2014 March 20 09:16:56 »
Hi Dave,

Unfortunately, Mac OS X limits the maximum number of open files to 256. See this thread for a similar problem report and a possible solution:

http://pixinsight.com/forum/index.php?topic=6871.0

When the maximum open files limit is surpassed, the current version of PixInsight crashes in a thread that monitors the filesystem as a background task. Hopefully we'll avoid this crash in the next version, but please note that the 256 open files limit is something we have no control over.

For integration of large sets of more than ~200 images, I recommend working on Linux or Windows.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline hhoover

  • Newcomer
  • Posts: 2
    • View Profile
Re: Image integration issues (too many open files)
« Reply #2 on: 2015 June 19 19:28:02 »
Hi - I have a solution to this problem for Mac OS X 10.10 (Yosemite).
I've done just about every combination of ulimit changes which does NOT resolve this.
For Yosemite, you need to create a startup LaunchDaemon, which runs launchctl and sets maxfiles.
The method:
cat > limit.maxfiles.plist
<paste the following text - without this line>
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
  <plist version="1.0">
    <dict>
      <key>Label</key>
        <string>limit.maxfiles</string>
      <key>ProgramArguments</key>
        <array>
          <string>launchctl</string>
          <string>limit</string>
          <string>maxfiles</string>
          <string>65536</string>
          <string>65536</string>
        </array>
       <key>RunAtLoad</key>
        <true/>
      <key>ServiceIPC</key>
        <false/>
    </dict>
  </plist>
^d <to end the file>
or - run an editor, paste in the text (without the ^d) and save to limit.maxfiles.plist
Now, copy that file to the right location:
sudo cp limit.maxfiles.plist /Library/LaunchDaemons/
Password:<your password here>

done! now, reboot.
When running again, try
launchctl limit maxfiles
in a terminal window - it should return:
   maxfiles    65536          65536         

Celebrate!
and run ImageIntegration those 830 files!

Note that I also have:
ulimit -n 10240
at the end of both my .profile and .login files in my home directory.
Someday, I'll remove them and see if my solution above still works.

--Hugh

Online pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4691
    • View Profile
Re: Image integration issues
« Reply #3 on: 2015 June 19 20:20:51 »
that's great - i will try this. i can't remember if i was messing with ulimit or maxfiles… as i mentioned in other threads when i fiddled with this (on 10.8 IIRC) the machine became kind of unstable. hopefully this technique yields different results.

rob

Offline hhoover

  • Newcomer
  • Posts: 2
    • View Profile
Re: Image integration issues
« Reply #4 on: 2015 June 21 23:16:48 »
> ... became kind of unstable..
yeah - if you're not careful, it's possible to set the limit lower (there's both a soft and hard limit), in which case, the system locks up because it can't open a new file...  I hit that trying launchctl from the command line.  Had to hard kill the machine.  But this method sets both the soft and hard limit to 65536, which is higher than the standard system setting for files of 10240.  That means it won't be preventing files from being opened.

--Hugh