Author Topic: PI 1.8.0.1054 - CosmeticCorrection doesn't work  (Read 2257 times)

Offline Andres.Pozo

  • PTeam Member
  • PixInsight Padawan
  • ****
  • Posts: 912
    • View Profile
PI 1.8.0.1054 - CosmeticCorrection doesn't work
« on: 2013 November 30 03:50:49 »
Hi,

In the latest version of PI the automatic hot pixel detection in CosmeticCorrection doesn't work. It detects a very high number of hot pixels and this number doesn't change when the sigma parameter changes.

The two attached images show this effect. I can provide a test image if necessary.

Offline StefanG

  • Newcomer
  • Posts: 19
    • View Profile
Re: PI 1.8.0.1054 - CosmeticCorrection doesn't work
« Reply #1 on: 2013 November 30 04:44:22 »
Hi everybody,

I found this behaviour this morning as well. Cosmetic correction with the Masterdark seems to work ok, though.

Best regards,

Stefan
GSO RC10
QSI583wsg, SX Lodestar Guider
AP Mach 1 Mount, Eagle Pier
PixInsight, MaximDL, CCD Commander

Offline bitli

  • PTeam Member
  • PixInsight Guru
  • ****
  • Posts: 508
    • View Profile
Re: PI 1.8.0.1054 - CosmeticCorrection doesn't work
« Reply #2 on: 2013 November 30 11:32:28 »
Seen it also, I compared between PI1.8RC7 and 1054, the auto detection is reasonable on 1.8RC7 but useless on 1.8 1054 (tested on star field badly calibrated)
-- bitli

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6828
    • View Profile
    • http://pixinsight.com/
Re: PI 1.8.0.1054 - CosmeticCorrection doesn't work
« Reply #3 on: 2013 December 01 12:17:37 »
This won't happen on the final 1.8.0 release. Thank you for detecting this problem.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline StefanG

  • Newcomer
  • Posts: 19
    • View Profile
Re: PI 1.8.0.1054 - CosmeticCorrection doesn't work
« Reply #4 on: 2013 December 08 01:20:49 »
I can confirm that in build 1065 CosmeticCorrection works as before again. Thank you very much for the fix.
Stefan
GSO RC10
QSI583wsg, SX Lodestar Guider
AP Mach 1 Mount, Eagle Pier
PixInsight, MaximDL, CCD Commander

Offline NKV

  • PTeam Member
  • PixInsight Guru
  • ****
  • Posts: 677
    • View Profile
Re: PI 1.8.0.1054 - CosmeticCorrection doesn't work
« Reply #5 on: 2013 December 12 18:47:06 »
In the latest version of PI the automatic hot pixel detection in CosmeticCorrection doesn't work.
At build 1065, I don't see that problem with my images. Please share with me one of your fit and settings.xpsm file.
« Last Edit: 2013 December 13 01:24:27 by NKV »

Offline NKV

  • PTeam Member
  • PixInsight Guru
  • ****
  • Posts: 677
    • View Profile
Re: PI 1.8.0.1054 - CosmeticCorrection doesn't work
« Reply #6 on: 2013 December 12 18:52:34 »
build 1065 - doesn't work in DefectList+CFA mode In LiveView show wrong pixel data. But processed images is ok.
Formally, it's happen if image less then 13x13 pixels. Because MT process required image more then 13x13 pixels.
So, it's not bug of CC, it's problem of MT.
« Last Edit: 2013 December 13 01:23:23 by NKV »