Author Topic: dslr image- persisting color gradient problem  (Read 1966 times)

Offline astrodoc71

  • PixInsight Enthusiast
  • **
  • Posts: 91
    • View Profile
dslr image- persisting color gradient problem
« on: 2013 November 01 16:05:54 »
Not sure what else to try. This is a star-rich wide field milky way shot. There is a persisting gradient, blue on the bottom, green on the top. I've tried separating the channels and using DBE with each, then recombining. I've tried background neutralization. I've tried different settings in color calibration. The best combo appears to be a small patch of background with a nearby white reference in the middle of the image. Structure detection was way worse. However, the gradient is still there. I tried auto histogram to see if I could equalize things and that helps a little but it is still there, especially when I increase saturation. Not sure what else to do? I'm pretty certain I have the right matrix pattern (RGGB) as it displays in the process console when the raw files open.
Thanks
Dave

Offline NGC7789

  • PixInsight Old Hand
  • ****
  • Posts: 391
    • View Profile
Re: dslr image- persisting color gradient problem
« Reply #1 on: 2013 November 01 16:23:45 »
Can you post a link to the .fit of the integration before any other processing so we can see what your seeing?

And what camera is it?

Offline astrodoc71

  • PixInsight Enthusiast
  • **
  • Posts: 91
    • View Profile
Re: dslr image- persisting color gradient problem
« Reply #2 on: 2013 November 01 18:29:03 »
Camera is a Canon EOS T3. The calibrated, debayered, integrated file can be downloaded here: https://www.adrive.com/public/CHYXMQ/cygnus%20sum1.fit
 It's about 140MB

Offline NGC7789

  • PixInsight Old Hand
  • ****
  • Posts: 391
    • View Profile
Re: dslr image- persisting color gradient problem
« Reply #3 on: 2013 November 02 09:05:25 »
Here's my attempt. I didn't have trouble getting rid of the gradient. I applied DBE using generated samples. I had to tweak the parameters a bit to generate enough. Then it was background neutralization and color calibration using the same preview of a bunch of stars off the Milky Way. Also SCNR to get rid of the green cast. Then just HT and Curves.

Offline astrodoc71

  • PixInsight Enthusiast
  • **
  • Posts: 91
    • View Profile
Re: dslr image- persisting color gradient problem
« Reply #4 on: 2013 November 02 12:57:56 »
Very good! The green is definitely gone. I will try SCNR. So you used the same background for BN as you did in color cal? What method in color calibration? Did you use a white reference, structure detection or what?
Thanks!
Dave

Offline NGC7789

  • PixInsight Old Hand
  • ****
  • Posts: 391
    • View Profile
Re: dslr image- persisting color gradient problem
« Reply #5 on: 2013 November 02 14:15:57 »
I did use the same preview for both backgraound in BN, as well as background reference and white balance in color cal using structure detection with default settings. Nothing says they have to be different previews. I have attached a screenshot so you can see where my preview was. I suppose you could use a preview of the star cloud and turn off structure detection and treat it like a galaxy reference but since I know there's a lot of nebulosity in that region I didn't want that to through off the white balance. I quicky reprocessed doing just that and couldn't actually see much difference.

Remember that for color calibration you just want a lot of stars so their average tends toward a true white reference. It doesn't really matter if you get there through a dense star region or a galaxy. You just want to avoid colorful objects like nebulae that can through off the star average. I've even seen where parts of galaxies that have too much resolved Ha regions, like M33, through off the white balance.

Offline astrodoc71

  • PixInsight Enthusiast
  • **
  • Posts: 91
    • View Profile
Re: dslr image- persisting color gradient problem
« Reply #6 on: 2013 November 06 11:11:24 »
Thanks! That really works!
Regards
Dave