Author Topic: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?  (Read 4066 times)

Offline james7

  • Member
  • *
  • Posts: 53
    • View Profile
1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« on: 2013 March 29 19:46:10 »
RC5 doesn't seem to run on Mac OS 10.6.8 (crash on launch, first generation Mac Pro with twin 2.66GHz Xeon processors and 10GB DRAM). Here is the relevant section from the  Mac OS X crash report:

Dyld Error Message:
  Symbol not found: __dispatch_source_type_vm
  Referenced from: /Applications/PixInsight.app/Contents/MacOS/../Frameworks/QtWebKit.framework/Versions/4/QtWebKit
  Expected in: /usr/lib/libSystem.B.dylib
 in /Applications/PixInsight.app/Contents/MacOS/../Frameworks/QtWebKit.framework/Versions/4/QtWebKit

This looks like it may be the same problem that was documented in the RC4 release and here is what you announced with that candidate (on March 12):

"This version is not compatible with Mac OS X 10.6 (Snow Leopard). This is due to a problem with the WebKit library, which PI uses to implement its document browsers. We'll release a special version for OS X 10.6 as soon as possible."

Should I assume that this is still a problem with RC5?

Offline Lex

  • PixInsight Guru
  • ****
  • Posts: 555
  • We do it at night...
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #1 on: 2013 March 30 13:35:36 »
Hi,

strange! RC5 really runs fast on my mac? Although I have a MacBook Pro 2.8GHz Intel Core 2 Duo, 8GB 1067 MHz DDR3, OS X 10.8.3.
I do not see why RC5 wouldn't run on your machine? On of the Guru's will surely know what's the problem...

Best
Clear Skies!!

Lex

______________________________________

AZEQ6 GT, TS UNC 10" f5, ASI1600mm-c

HADSO (Hagen Deep Sky Observatory)20 km W of Luxemburg City

Offline james7

  • Member
  • *
  • Posts: 53
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #2 on: 2013 March 30 15:33:40 »
Hi,

strange! RC5 really runs fast on my mac? Although I have a MacBook Pro 2.8GHz Intel Core 2 Duo, 8GB 1067 MHz DDR3, OS X 10.8.3.
I do not see why RC5 wouldn't run on your machine? On of the Guru's will surely know what's the problem...

Best
It's a question about the Mac OS X operating system and what versions RC5 will run under. Unfortunately, Apple has seen fit to end support for the first generation, Intel Mac Pro machines and I can't run 10.8 (Mountain Lion). So, here I sit with a machine that should be notably faster than what you have and yet I can't run the latest operating system from Apple. I hope the same is not true with PixInsight 1.8.

Offline Lex

  • PixInsight Guru
  • ****
  • Posts: 555
  • We do it at night...
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #3 on: 2013 March 31 00:11:41 »
Hi,

Wow that's not real good publicity for apple :surprised:
What a shame that you can not use your Mac as you want it!
What year is it from then?

Best
Clear Skies!!

Lex

______________________________________

AZEQ6 GT, TS UNC 10" f5, ASI1600mm-c

HADSO (Hagen Deep Sky Observatory)20 km W of Luxemburg City

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6873
    • View Profile
    • http://pixinsight.com/
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #4 on: 2013 March 31 15:57:29 »
Hi James,

I apologize for this problem. I'll build a special version for OS X 10.6 as soon as possible. With PI 1.8 I have tried to keep compatibility with 10.6, and I have achieved it with a single exception: the WebKit library. Unfortunately, the only way to get a Snow Leopard compatible WebKit build is building it on Snow Leopard. Since we have moved all our build and test system to the new iMac with 10.8, building on a different machine adds a layer of complexity that we haven't been able to afford, given the difficulties we have had with PI 1.8. Now that we have a stable release, we can work to fix this problem. Not before April 10th though, since I'm having a few days of "rest"...
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline james7

  • Member
  • *
  • Posts: 53
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #5 on: 2013 April 01 02:19:09 »
Juan, thanks for the update. It's no burden at the moment for me to go back to v1.7, I've kept a copy in case things didn't work out with v1.8.

Frankly, if you can't build a universal version that will work on 10.6 and 10.7/10.8 then maybe it is time to document that and end support for Snow Leopard. My first generation Mac Pro can run 10.7/Lion, it's just that I've kept on 10.6 because it works well with the remainder of my installed software (as the saying goes, "If it ain't broke, don't try to fix it.")

Offline alintolea

  • Newcomer
  • Posts: 4
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #6 on: 2013 April 13 19:01:45 »
Hi,

please don't discontinue support for snow leopard. It's a 64 bit OS with enough resources, still fully supported by Apple, and not everyone likes Mountain Lion (not to mention the pain of reinstalling software packages).

So, I have snow leopard and PI RC5 won;t install. Did you have a chance to make that special build?

Thanks!

Alin



Juan, thanks for the update. It's no burden at the moment for me to go back to v1.7, I've kept a copy in case things didn't work out with v1.8.

Frankly, if you can't build a universal version that will work on 10.6 and 10.7/10.8 then maybe it is time to document that and end support for Snow Leopard. My first generation Mac Pro can run 10.7/Lion, it's just that I've kept on 10.6 because it works well with the remainder of my installed software (as the saying goes, "If it ain't broke, don't try to fix it.")
Alin Tolea
Washington DC area

Offline manni_m

  • Newcomer
  • Posts: 2
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #7 on: 2013 April 22 07:59:17 »
Quote
please don't discontinue support for snow leopard

May I sign here for this as well... I cant leave 10.6.8 for the time being because Im running a very complex but stable (music) production environment on my mac and it would take me a month and tons of headdache to ungrade to 10.7 or higher, so please please find an old mac to compile that version soon   O:)

thx a lot
manni

Offline alintolea

  • Newcomer
  • Posts: 4
    • View Profile
Re: 1.8RC5 and Mac OS X 10.6.8 (Snow Leopard)?
« Reply #8 on: 2013 April 22 09:02:15 »
Hi Juan,

Still waiting on a reply, I see Ripley is out..

Alin

Quote
please don't discontinue support for snow leopard

May I sign here for this as well... I cant leave 10.6.8 for the time being because Im running a very complex but stable (music) production environment on my mac and it would take me a month and tons of headdache to ungrade to 10.7 or higher, so please please find an old mac to compile that version soon   O:)

thx a lot
manni
Alin Tolea
Washington DC area