Author Topic: Bug in the "Save as..." function?  (Read 1864 times)

Offline rodolgo

  • Newcomer
  • Posts: 17
    • View Profile
Bug in the "Save as..." function?
« on: 2012 January 29 06:46:03 »
Hi,

I've noticed that if the characters "(" or ")" are present in the full path name, then I receive an error when saving the file:

Quote
Writing file:
C:/Users/rodolgo/Pictures/Astro/2012-01-16 IC 434 (Horsehead Nebula)/Traitements/IC 434 DSS test.FTS
*** PCL Exception: PCL FITS Format Support: Unable to create FITS file:
C:/Users/rodolgo/Pictures/Astro/2012-01-16 IC 434 (Horsehead Nebula)/Traitements/IC 434 DSS test.FTS
<* failed *>

Opening it is not an issue, though:

Quote
open "file:///C:/Users/rodolgo/Pictures/Astro/2012-01-16 IC 434 (Horsehead Nebula)/Traitements/IC 434 DSS.FTS"
Reading 1 file(s):
C:/Users/rodolgo/Pictures/Astro/2012-01-16 IC 434 (Horsehead Nebula)/Traitements/IC 434 DSS.FTS
Reading FITS: 32-bit floating point, 3 channel(s), 4279x2748 pixels: 100%

Removing the "(" and ")" characters in the path name solves the issue. I've not tried other exotic characters nor other formats...

I'm running this version of PixInsight:

Quote
version
PixInsight Core 01.07.04.0759 Starbuck (x86_64)
PCL 01.00.97.0383
Copyright (C) 2003-2011 Pleiades Astrophoto

HTH,

Rodolphe

Offline Nocturnal

  • PixInsight Jedi Council Member
  • *******
  • Posts: 2727
    • View Profile
    • http://www.carpephoton.com
Re: Bug in the "Save as..." function?
« Reply #1 on: 2012 January 30 07:42:53 »
It's a limitation of cfitsio. You can probably find related discussions on this forum.
Best,

    Sander
---
Edge HD 1100
QHY-8 for imaging, IMG0H mono for guiding, video cameras for occulations
ASI224, QHY5L-IIc
HyperStar3
WO-M110ED+FR-III/TRF-2008
Takahashi EM-400
PIxInsight, DeepSkyStacker, PHD, Nebulosity

Offline georg.viehoever

  • PTeam Member
  • PixInsight Jedi Master
  • ******
  • Posts: 2131
    • View Profile
Re: Bug in the "Save as..." function?
« Reply #2 on: 2012 January 30 08:14:17 »
Proposal to Juan: Could you create a "known issues" list. This problem now has been discovered for the n-th time. This kind of problems is an unnecessary burden for new users.

Georg
Georg (6 inch Newton, unmodified Canon EOS40D+80D, unguided EQ5 mount)

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6828
    • View Profile
    • http://pixinsight.com/
Re: Bug in the "Save as..." function?
« Reply #3 on: 2012 January 30 12:53:24 »
Quote
Could you create a "known issues" list

Yes, I agree that's very necessary. Thank you for pointing this out.

In this case, what I'm going to do is to release a new version of the FITS support module where parentheses and other problematic characters will be automatically replaced with underscores. I don't like this kind of 'intrusive' solutions but I think it's the best option to solve this recurring problem once and for all.

Another solution would be hacking CFITSIO, but frankly, I'd prefer to stay as far as possible from that 'thing'. The best solution would be not depending on CFITSIO anymore, but right now I have much better things to do than writing new FITS support code.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline rodolgo

  • Newcomer
  • Posts: 17
    • View Profile
Re: Bug in the "Save as..." function?
« Reply #4 on: 2012 January 31 15:05:06 »
You know what?  just a more informative error message would help. We are big boys out here (well, I dare believe ;)) it's much easier to correct on our end than on yours.

The "known issues" list would also be a very helpful feature.

My 2 cents,

Rodolphe