Author Topic: Mask toolbar icons working "the other way"  (Read 2137 times)

Offline RBA

  • PixInsight Guru
  • ****
  • Posts: 507
    • View Profile
    • DeepSkyColors
Mask toolbar icons working "the other way"
« on: 2011 February 20 09:28:15 »
The mask toolbar icons started working "the other way" for me about 2-3 weeks ago.

Meaning... When one of those icons looks "selected", it's in fact the opposite.

So when the star icon (show mask) is "selected", I do NOT see the mask, when it's "selected" I can see it. Same thing for the invert mask and enable/disable mask. They work the other way around.

Quite confusing if you ask me.

This is on a Win7 machine (x86_64) and the 01.06.09.0652 build.

I have thought about resetting my preferences to see what happens, but if this is a bug I'd rather it gets fixed than killing my prefs.



« Last Edit: 2011 February 20 09:34:57 by RBA »

Offline Enzo De Bernardini

  • PTeam Member
  • PixInsight Addict
  • ***
  • Posts: 271
  • Resistance is futile.
    • View Profile
    • Astronomí­a Sur
Re: Mask toolbar icons working "the other way"
« Reply #1 on: 2011 February 20 11:47:08 »
Do you happen to have disabled the splash screen? My UI problems were solved when I activate them again (Win XP 32)

Greetings,

Enzo.

Offline RBA

  • PixInsight Guru
  • ****
  • Posts: 507
    • View Profile
    • DeepSkyColors
Re: Mask toolbar icons working "the other way"
« Reply #2 on: 2011 February 20 11:57:01 »
Do you happen to have disabled the splash screen? My UI problems were solved when I activate them again (Win XP 32)

I have it disabled, yes.
I don't want to close my current session at this time (where oh where is the "save project" feature? ;) ) but I'll definitely check that out and confirm when I have a chance.
That'd be an interesting side effect to say the least!
Thanks for the tip.

Online Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6873
    • View Profile
    • http://pixinsight.com/
Re: Mask toolbar icons working "the other way"
« Reply #3 on: 2011 February 21 02:52:03 »
Well, it seems we have some problems with the interface updater task in version 1.6.9 on Windows.

The interface updater is a low-priority background task that is running permanently in the PixInsight Core application (except during process execution, where it is stopped temporarily) and its purpose is to ensure coherence of the whole graphical interface. The interface updater 'sleeps' during 250 milliseconds and then wakes up to inspect all the relevant objects and components in the whole platform. When it encounters a change from the last fetched state, it updates the corresponding GUI element (say a tool button image, a menu item, a checkbox state or a listbox item, for example). This implementation is very nice and efficient, especially in a complex application like PixInsight. This is what is not working correctly on your Windows installations, for some reason that eludes me, and the cause of the odd problems that you're experiencing.

I'm unable to reproduce this problem on Windows Vista, 7 and XP. The relation with the splash screen is indeed really odd. I'll dig into this to fix it as soon as possible; sorry for the inconvenience.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline RBA

  • PixInsight Guru
  • ****
  • Posts: 507
    • View Profile
    • DeepSkyColors
Re: Mask toolbar icons working "the other way"
« Reply #4 on: 2011 February 21 12:20:22 »
Thanks for the info Juan.

I enabled the splash screen and restarted PixInsight.
So far I don't see the problem but I've only ran minimal tests.
I'll let you know if it happens again.

Offline RBA

  • PixInsight Guru
  • ****
  • Posts: 507
    • View Profile
    • DeepSkyColors
Re: Mask toolbar icons working "the other way"
« Reply #5 on: 2011 February 23 14:24:17 »
It is still happening, splash or no splash...
Yet, I can't reproduce it systematically.
Guess it usually happens when I'm actually using the program rather than trying to replicate the problem  ::)
If I see a pattern I'll post it here...