Author Topic: /usr/lib/libxml2.so.2: undefined symbol: gzopen64 *WORKAROUND*  (Read 7800 times)

Offline chris.baron

  • Newcomer
  • Posts: 15
    • View Profile
Quote
/home/cbaron/PixInsight/bin/./PixInsight: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64

Juan wrote:
Sorry for that Chris. I'll include libxml2.so in the bin/lib directory of all PI's Linux distributions to avoid these problems.

Juan,

As it turns out I managed to get by this. It wasn't that I was missing libxml2 (installed as part of my Ubuntu install) but rather the version of libz that is included in the PixInsight distribution references gzopen64. Moving the libz files out of PixInsight's library path allowed me to work without issue. This might be a just a problem for Ubuntu users, (I'm now running what is essentially the GM of 10.04) but I thought I'd pass on what worked for me just in case.

Cheers,
Chris

Offline Carlos Milovic

  • PTeam Member
  • PixInsight Jedi Master
  • ******
  • Posts: 2173
  • Join the dark side... we have cookies
    • View Profile
    • http://www.astrophoto.cl
Re: /usr/lib/libxml2.so.2: undefined symbol: gzopen64 *WORKAROUND*
« Reply #1 on: 2010 April 30 10:15:55 »
Hi
 I had the same problem with the new Ubuntu. Thanks for the workaround :)
Regards,

Carlos Milovic F.
--------------------------------
PixInsight Project Developer
http://www.pixinsight.com

Offline chris.baron

  • Newcomer
  • Posts: 15
    • View Profile
Re: /usr/lib/libxml2.so.2: undefined symbol: gzopen64 *WORKAROUND*
« Reply #2 on: 2010 April 30 12:49:41 »
Glad I was able to help  :D