Author Topic: Weighted Batch Preprocessing Script issues and Batch Preprocessing issue as well  (Read 202 times)

Offline ecoles

  • Newcomer
  • Posts: 28
    • View Profile
I was excited to read about the WBPP script. I updated PI and downloaded and installed the new script. I decided to run the same M45 data just completed on the standard BPP script. All the information was loaded and checked. The Diagnostics button was "Completed and OK", so I ran the script. The result was a Smart Report with errors and not stacked data. Here is the text of that report. Not sure what to do next?

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

[Calibration data]
  Master bias: Z:/SRO files/20190501/master/bias-BINNING_1.xisf
  Master dark: Z:/SRO files/20190501/master/dark-BINNING_1-EXPTIME_600.xisf
  Master flat: Z:/SRO files/20191118 M45/master/flat-FILTER_B-BINNING_1.xisf
Calibration completed
Cosmetic Correction OK
************************************************************

************************************************************
Group of 12 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

[Calibration data]
  Master bias: Z:/SRO files/20190501/master/bias-BINNING_1.xisf
  Master dark: Z:/SRO files/20190501/master/dark-BINNING_1-EXPTIME_600.xisf
  Master flat: Z:/SRO files/20191118 M45/master/flat-FILTER_G-BINNING_1.xisf
Calibration completed
Cosmetic Correction OK
************************************************************

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

[Calibration data]
  Master bias: Z:/SRO files/20190501/master/bias-BINNING_1.xisf
  Master dark: Z:/SRO files/20190501/master/dark-BINNING_1-EXPTIME_600.xisf
  Master flat: Z:/SRO files/20191118 M45/master/flat-FILTER_R-BINNING_1.xisf
Calibration completed
Cosmetic Correction OK
************************************************************

Reference frame for registration: Z:/SRO files/20191118 M45/M45 RGB-S001-R001-C001-B-PA000 Ref.xisf

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

Registration OK
Frame weights succesfully computed and stored after registration
!!! Error: Error integrating light frames.
************************************************************

************************************************************
Group of 12 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

Registration OK
Frame weights succesfully computed and stored after registration
!!! Error: Error integrating light frames.
************************************************************

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

Registration OK
Frame weights succesfully computed and stored after registration
!!! Error: Error integrating light frames.
************************************************************


Second and Third Issue:
And that's not all. I tried making a drag copy of the script with all parameters inserted, using the New Instance triangle. I usually do this to reuse the scripts setup from target to target with new data. Almost none of the information was saved, no Lights, Flats, Darks or Bias frames  were there when I used the New Instance copy to restart the script. The reference frame and directory link were retained. This has always worked in the past.

Another issue. None of my saved Batch Preprocessing copies work either. they all give an Error: Source code MD5 checksum mismatch:

This means all my saved setups for the various rotation angle that are saved in Batch Preprocessing new instance icons are lost in the latest install of PI.

I would appreciate some guidance on what to do next.

Thanks. Eric

Offline robyx

  • Newcomer
  • Posts: 42
    • View Profile
Hi Eric,

there were definitely an issue during the Image Integration steps. The best way to investigate is to read the last log file you can find in the logs folder. Can you attach it here? In that files very detailed information are written and so we can investigare deeper.

Regards,
Robyx

I was excited to read about the WBPP script. I updated PI and downloaded and installed the new script. I decided to run the same M45 data just completed on the standard BPP script. All the information was loaded and checked. The Diagnostics button was "Completed and OK", so I ran the script. The result was a Smart Report with errors and not stacked data. Here is the text of that report. Not sure what to do next?

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

[Calibration data]
  Master bias: Z:/SRO files/20190501/master/bias-BINNING_1.xisf
  Master dark: Z:/SRO files/20190501/master/dark-BINNING_1-EXPTIME_600.xisf
  Master flat: Z:/SRO files/20191118 M45/master/flat-FILTER_B-BINNING_1.xisf
Calibration completed
Cosmetic Correction OK
************************************************************

************************************************************
Group of 12 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

[Calibration data]
  Master bias: Z:/SRO files/20190501/master/bias-BINNING_1.xisf
  Master dark: Z:/SRO files/20190501/master/dark-BINNING_1-EXPTIME_600.xisf
  Master flat: Z:/SRO files/20191118 M45/master/flat-FILTER_G-BINNING_1.xisf
Calibration completed
Cosmetic Correction OK
************************************************************

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

[Calibration data]
  Master bias: Z:/SRO files/20190501/master/bias-BINNING_1.xisf
  Master dark: Z:/SRO files/20190501/master/dark-BINNING_1-EXPTIME_600.xisf
  Master flat: Z:/SRO files/20191118 M45/master/flat-FILTER_R-BINNING_1.xisf
Calibration completed
Cosmetic Correction OK
************************************************************

Reference frame for registration: Z:/SRO files/20191118 M45/M45 RGB-S001-R001-C001-B-PA000 Ref.xisf

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

Registration OK
Frame weights succesfully computed and stored after registration
!!! Error: Error integrating light frames.
************************************************************

************************************************************
Group of 12 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

Registration OK
Frame weights succesfully computed and stored after registration
!!! Error: Error integrating light frames.
************************************************************

************************************************************
Group of 15 Light frames
BINNING  : 1
NoFilter
Exposure : 600.00s

Registration OK
Frame weights succesfully computed and stored after registration
!!! Error: Error integrating light frames.
************************************************************


Second and Third Issue:
And that's not all. I tried making a drag copy of the script with all parameters inserted, using the New Instance triangle. I usually do this to reuse the scripts setup from target to target with new data. Almost none of the information was saved, no Lights, Flats, Darks or Bias frames  were there when I used the New Instance copy to restart the script. The reference frame and directory link were retained. This has always worked in the past.

Another issue. None of my saved Batch Preprocessing copies work either. they all give an Error: Source code MD5 checksum mismatch:

This means all my saved setups for the various rotation angle that are saved in Batch Preprocessing new instance icons are lost in the latest install of PI.

I would appreciate some guidance on what to do next.

Thanks. Eric

Offline ecoles

  • Newcomer
  • Posts: 28
    • View Profile
Where exactly is the log file?

Equally disturbing is the inability to save an instance of the WBPP and the fact that previous instances of the BPP script will not run.

Offline ecoles

  • Newcomer
  • Posts: 28
    • View Profile
There was an update to the WBPP script that was installed when I quit PI. That seemed to solve the problems described above. That is, the script ran without an issue and I was able to save instances and restart them.

Now on to understanding more about the new script. :-)

Offline robyx

  • Newcomer
  • Posts: 42
    • View Profile
Good to know! :)

Robyx

There was an update to the WBPP script that was installed when I quit PI. That seemed to solve the problems described above. That is, the script ran without an issue and I was able to save instances and restart them.

Now on to understanding more about the new script. :-)