Author Topic: Mosaic of a mosaic not aligning correctly...  (Read 235 times)

Offline John_Gill

  • PixInsight Old Hand
  • ****
  • Posts: 345
    • View Profile
Mosaic of a mosaic not aligning correctly...
« on: 2019 October 23 00:15:26 »
Hi,

Over two nights I took 2 sets of images - NGC261 and NGC345 in both Ha and Oiii of the Small Magellanic Cloud. I pre-processed these 4 image sets and then stopped before stretching.

Using StarAlignment (Register/Union - Mosaic)  I create a 2 panel mosaic of the Ha and another 2 panel mosaic using the Oiii. Both mosaics align 100%and look decent.  There is a lot of black space around each image due to the StarAlignment image rotation. So I now have 2 x two panel mosaic, namely "mosaic_Ha" and "mosaic_Oiii".  Placing the images over each other, I can see the alignment looks great.

I now re-register the two mosaics to each other and 100% result.  All is still good. I now combine these images using ChannelCombination or LRGBCombination.
Now the problem starts .... When zooming into the result, I can see that the Ha and Oii on the left image match up but the filter colors on right image do not match up.  To the point that the stars are off by about 1.5 stars (I hope that makes sense). 

I have tried stretching the images before doing the ChannelCombination, but with the same result.

Any ideas will be appreciated
John
APM 107/700 apo on CGX mount
ZWO Optics - Autoguiding
ZWO1600mm and filters
... when there are no clouds ...

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 7028
    • View Profile
    • http://pixinsight.com/
Re: Mosaic of a mosaic not aligning correctly...
« Reply #1 on: 2019 October 23 03:12:00 »
Hi John,

I can't help you without playing with the same images you are trying to register as a mosaic. Can you upload them?
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline John_Gill

  • PixInsight Old Hand
  • ****
  • Posts: 345
    • View Profile
Re: Mosaic of a mosaic not aligning correctly...
« Reply #2 on: 2019 October 23 03:48:17 »
Hi Juan,

I have upload the 2 separate mosaic files in Ha and Oiii to Google Drive.
https://drive.google.com/open?id=0B1V2LqJCaPPib190UE0xQ2lMWDA

Thanks for taking the time to have  a look.

John
APM 107/700 apo on CGX mount
ZWO Optics - Autoguiding
ZWO1600mm and filters
... when there are no clouds ...

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 7028
    • View Profile
    • http://pixinsight.com/
Re: Mosaic of a mosaic not aligning correctly...
« Reply #3 on: 2019 October 23 04:36:16 »
Hi John,

The problem with these images is that they are out of focus. The new distortion correction algorithm implemented in StarAlignment requires accurate PSF fits for robust star detection. Unfocused stars have irregular distributions and flat profiles, which makes centroid determination uncertain. With its default parameters, SA cannot compute a valid local distortion model for these images.

However, you can tweak a couple of parameters to register these mosaics very accurately (to the accuracy that is achievable with out-of-focus images, that is):

- Set the peak response parameter to 1 (Star Detection section). This is necessary because the stars in these images are flat with relatively weak peaks, so SA's star detector must be more peak-sensitive than usual to detect some of them.

- Click the Edit Instance Source Code button (empty square, bottom right corner).

- On the source code editor window, look for the psfTolerance parameter. Its default value is 0.5 pixels:

P.psfTolerance = 0.50;

Change it to 2 pixels:

P.psfTolerance = 2;

- Click the Commit button (green check mark, top right corner).

- Set Registration model to Thin Plate Splines.

- Enable the Distortion correction and Local distortion options.

- Select the Ha image as registration reference.

- Apply the process to the OIII image.

- Use ChannelCombination with the Ha image and the registered OIII image.

See the attached screenshot. With these changes these images can be registered very well. I encourage you to fix these focusing problems; you'd have a very nice mosaic without them.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline John_Gill

  • PixInsight Old Hand
  • ****
  • Posts: 345
    • View Profile
Re: Mosaic of a mosaic not aligning correctly...
« Reply #4 on: 2019 October 23 06:01:19 »
Hi Juan,

Thanks for your time and effort.  I will re-look at my focus and redo the SMC.

space is not black'
Joh
APM 107/700 apo on CGX mount
ZWO Optics - Autoguiding
ZWO1600mm and filters
... when there are no clouds ...