Author Topic: Dark frame optimization threshold is probably too high and System Exception  (Read 195 times)

Offline dnewell

  • Newcomer
  • Posts: 10
    • View Profile
I was doing an ImageCalibration on some flat frames.  Using the standard defaults, and under Master Bias, I did not check calibrate, and under Master Dark, I checked both calibrate and optimize.   This is what resulted:

ImageCalibration: Global context

Loading master calibration frames:
Loading calibration frame image:
I:/Astrophotos/Bias Frames/ZWO ASI1600MM Pro/MasterSuperBias_bin-1_gain-139.xisf
Loading image: w=4656 h=3520 n=1 Gray Float32
430 FITS keyword(s) extracted.
Loading calibration frame image:
I:/Astrophotos/Dark Frames/ZWO ASI1600MM Pro/MasterDark_90s_-15c_bin-1_gain-139.xisf
Loading image: w=4656 h=3520 n=1 Gray Float32
221 FITS keyword(s) extracted.

Applying bias correction: master dark frame ...

Dark frame optimization thresholds:
Td0 = 0.00000000 (3 px = 0.000%)
** Warning: The dark frame optimization threshold is probably too high (channel 0).
** Warning: The dark frame optimization pixel set is too small - disabling dark frame optimization (channel 0).
*** PCL Win32 System Exception: At address 00007FF8DD38A388 with exception code C0000005 :
Access violation: invalid memory read operation at address 0000000000000008
<* failed *>

If I uncheck optimize, the process runs normally.

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4050
    • View Profile
you should upload the files (the masters and a light) so someone can take a look / reproduce the problem.

rob

Offline dnewell

  • Newcomer
  • Posts: 10
    • View Profile

Offline bulrichl

  • PixInsight Old Hand
  • ****
  • Posts: 300
    • View Profile
The MasterDark that you uploaded is captured with binning (2x2) and does not suit to the flat frame and superbias (binning 1x1). Therefore I get a different error: not compatible geometry. Please upload the suitable MasterDark.

Bernd

Offline dnewell

  • Newcomer
  • Posts: 10
    • View Profile
My apologies....here's the correct zip file.

https://www.dropbox.com/s/m46n4kkks02p1pk/PI.zip?dl=0


Offline bulrichl

  • PixInsight Old Hand
  • ****
  • Posts: 300
    • View Profile
Hi,

I took a look at your MasterSuperBias, MasterDark and flat frame.

The MasterSuperBias has a median of 751 ADU, the MasterDark only 133 ADU. So I guess that your MasterDark does not contain the bias, i. e. the bias was already subtracted from each dark frame before integration to the MasterDark, is that correct?

You wrote:
> I was doing an ImageCalibration on some flat frames.  Using the standard defaults, and under Master Bias, I did not check calibrate, and under Master Dark, I checked both calibrate and optimize.

The uploaded flat frame ("Flat_Lum_0000.210s_1x1_-12C_gain_Link Cam_c.xisf", exposure time: 0.21 s) is already calibrated according to both filename and FITS header. Did you try to calibrate the already calibrated flat frame for a second time? When did the error occur? I don't understand it.

-------------
Furthermore, in the FITS header of the calibrated flat frame, CCD-TEMP is -12 whereas SET-TEMP is -15. Obviously the cooler did not manage to reach the set temperature. This should be avoided by setting the set temperature to a value that can be reached. In other words: the cooling power shall be < 100 % (better < 80 %).

-------------
I suggest you to take the following approach (the existent dark frames and flat frames can be used here):

1) MasterFlat:
- take FlatDarks (= dark frames with the same exposure time as the flat frames, in your case: 0.21 s) and integrate them to the MasterFlatDark,
- calibrate the flat frames with the MasterFlatDark,
- integrate the calibrated flat frames to the MasterFlat.

2) MasterDark:
- take dark frames (same exposure time as the light frames) and integrate them to the MasterDark.

3) Light frame calibration:
- calibrate the light frames with the MasterDark (uncheck both 'Calibrate' and 'Optimize' in the 'Master Dark' section) and the MasterFlat (uncheck 'Calibrate' in the 'Master Flat' section).

You don't need bias frames (... and MasterBias, MasterSuperBias).

After light frame calibration, CosmeticCorrection can optionally be applied. Then registrate and integrate.

Bernd