Author Topic: PhotometricColorCalibration fails but ImageSolver works  (Read 500 times)

Offline JST200

  • Newcomer
  • Posts: 18
    • View Profile
PhotometricColorCalibration fails but ImageSolver works
« on: 2019 February 26 03:47:48 »
Hi,

I'm sure it's me but every time I try a PhotometricColorCalibration it fails with "*** Error: Unable to find an initial set of putative star pair matches
*** Error: The image could not be aligned with the reference star field". :sad:

However, if I then run the image through ImageSolver, with exactly the same inputs, it solves within a few seconds. :)

If I then put the results from ImageSolver into PhotometricColorCalibration it then works!  ???

So they both start with:
Co-ords found search function (IC405):
  PhotometricColorCalibration co-ords = RA 5 17 24.000, Dec +34 23 00.00
  ImageSolver = RA 5 16 17.668, Dec 34 22 3.95
Focal Length = 750
Pixel size = 5.19

So co-ords are within about 1.5 arcmin of each other.

ImageSolver returns:
RA: 05 16 17.668  Dec: +34 22 03.94
Focal Length = 755.69

When I put these values into PhotometricColorCalibration, it solves OK and continues successfully.

Basically it seems that PhotometricColorCalibration is incredibly sensitive to location and/or Focal Length. Can I make it's solve function less sensitive?

If it helps, here is the stacked image of IC405 I'm trying to process (it's 431MB): https://1drv.ms/u/s!AgjJ1doGv5CshKIgh7gmaaSJbEWxiQ

Thanks for any help and advice!

Cheers, Jim

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6780
    • View Profile
    • http://pixinsight.com/
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #1 on: 2019 February 26 04:05:48 »
Hi Jim,

PCC calls the ImageSolver script internally, so the code that is being executed in both cases is exactly the same. If your images are mirrored with respect to star catalogs, a potential cause for this problem is the use of polygons for the star matching algorithm. Polygons are much better, but cannot handle mirroring in my current implementation (I'll overcome this limitation in a future version of StarAlignment).

On PCC, open the Advanced Plate Solving Parameters section and make sure the alignment device is set to Triangle similarity. Let me know if this helps.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline JST200

  • Newcomer
  • Posts: 18
    • View Profile
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #2 on: 2019 February 26 04:34:00 »
Hi Juan,

Thanks for the superfast reply!

I assumed that PCC used the ImageSolve function, which is why I thought it so strange that one works and the other doesn't.

I've just checked PCC is already set for Triangle similarity. I haven't changed this, so I assume that's the default?

It does appear there is a slight difference between PCC and ImageSolve, as theit Search for coordinates gives slightly different results (if only by an arcmin or two). Is it worth you trying a PCC with my image to see if it works for you?

Again, thanks for your help.

Cheers, Jim

Offline JST200

  • Newcomer
  • Posts: 18
    • View Profile
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #3 on: 2019 February 28 00:53:22 »
Hi Juan,

Have you any more suggestions to help resolve this?

Thanks, Jim :)

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6780
    • View Profile
    • http://pixinsight.com/
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #4 on: 2019 February 28 00:55:30 »
Hi Jim,

The only way I can help you is by trying out PCC with your image. Can you upload it (dropbox, etc)?
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6780
    • View Profile
    • http://pixinsight.com/
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #5 on: 2019 February 28 00:56:33 »
Oops! You already uploaded it! I'm a bit dense this morning :)
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6780
    • View Profile
    • http://pixinsight.com/
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #6 on: 2019 February 28 01:17:24 »
Hi Jim,

The problem is the FOCALLEN FITS header keyword in your image. It has a value of 50 mm. The PCC tool gives precedence to existing metadata over values specified on the graphical interface, so it is using 50 mm regardless of the correct value that you are entering. If you apply ImageSolver before PCC, it replaces the FOCALLEN keyword with the correct value, so PCC works.

The solution is simply removing the FOCALLEN keyword with the FITSKeywords tool. Once you remove it, PCC works perfectly if you enter approximate coordinates, focal length and pixel size values.

You may want to configure your camera to prevent writing these incorrect metadata values in acquired images through a telescope. It seems your camera thinks it has a 50 mm lens attached, which is obviously not true when you use it through a telescope.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline JST200

  • Newcomer
  • Posts: 18
    • View Profile
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #7 on: 2019 February 28 06:09:20 »
Hi Juan,

Thanks very much for the info and suggestions   :)

Quote
Oops! You already uploaded it! I'm a bit dense this morning

That's me every morning!  :laugh:

Quote
You may want to configure your camera to prevent writing these incorrect metadata

I've checked the camera and my Canon EOS 1100D doesn't seem to have such an option  :sad: So I'll use the FITSHeader process (seems easier than the FITSKeywords tool?

Can I make a couple of PCC suggestions?

Quote
The PCC tool gives precedence to existing metadata over values specified on the graphical interface

This seems very counter intuitive. In most programs, user input takes precedence and other inputs are considered defaults; how else can a user change an incorrect default value. So could this be changed or perhaps an option provided to ignore the FITS  value?

I notice the ImageSolver script maintains the user entered Focal Length and Pixel Size from one PI session to the next. PCC always default to Focal Length = 1000, Pixel Size = 9.0. Could PCC save the user input settings too?

Anyway, thanks once again for your help!

Cheers, Jim
« Last Edit: 2019 February 28 07:52:46 by JST200 »

Offline bulrichl

  • PixInsight Old Hand
  • ****
  • Posts: 405
    • View Profile
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #8 on: 2019 February 28 15:17:27 »
Hi Jim,

obviously you used the Canon raw format (CR2) for capturing. The camera (Canon EOS 1100D) is able to correctly detect the focal length of compatible lenses but will fail in case of a telescope.

Using the FITS format and setting the correct focal length in the capturing software would solve your problem.

Bernd

Offline STEVE333

  • PixInsight Addict
  • ***
  • Posts: 225
    • View Profile
    • sk-images
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #9 on: 2019 February 28 20:41:21 »
I have a Canon 1100D and also had problems with PCC. I use the raw CR2 files exclusively.

Someone (can't remember who) suggested checking the Force plate solving and Ignore existing metadata boxes.

THIS COMPLETELY SOLVED THE PROBLEM FOR ME!!!!!

Maybe it will work for you too. If it does it means you don't have to edit any file header data.

Steve
Telescopes:  WO Star71 ii, ES ED102 CF
Camera:  Canon T3 (modified)
Filters:  IDAS LPS-D1, Triad Tri-Band, STC Duo-Narrowband
Mount:  CEM40 EC
Software:  BYEOS, PHD2, PixInsight

http://www.SteveKing.Pictures/

Offline JST200

  • Newcomer
  • Posts: 18
    • View Profile
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #10 on: 2019 March 01 01:19:17 »
Hi Steve,

Yep! That worked for me too! Brilliant. Thanks! So obvious once you know! :D

When Juan said that the PCC Process took the FITS header metadata over human input I immediately thought of "DAVE: Open the pod bay doors, Hal. HAL: I'm sorry, Dave. I'm afraid I can't do that."  :-\ :D

Anyway, thanks to both of you for your help.

Cheers, Jim

Offline STEVE333

  • PixInsight Addict
  • ***
  • Posts: 225
    • View Profile
    • sk-images
Re: PhotometricColorCalibration fails but ImageSolver works
« Reply #11 on: 2019 March 01 08:44:51 »
You're welcome Jim, glad it worked.

I just wish I could remember who (somebody here in the PI Forum) passed the hint along to me so they could get the credit.

Enjoy.

Steve
Telescopes:  WO Star71 ii, ES ED102 CF
Camera:  Canon T3 (modified)
Filters:  IDAS LPS-D1, Triad Tri-Band, STC Duo-Narrowband
Mount:  CEM40 EC
Software:  BYEOS, PHD2, PixInsight

http://www.SteveKing.Pictures/