Author Topic: Subframeselector process : Graph Error : Invalid script execution  (Read 325 times)

Offline F83eric

  • Newcomer
  • Posts: 2
    • View Profile
Hi,
yesterday I use SFS process all is allright
Today when I click on the process Icon I have the message : Graph Error : Invalid script Execution on a box (before select file)
The graph doesn't appear

Pixinsight Core 01.08.06.1448 Ripley (x86)

Do you have Solution for my problem ?

Best regards

Offline sbenz

  • Newcomer
  • Posts: 6
    • View Profile
Re: Subframeselector process : Graph Error : Invalid script execution
« Reply #1 on: 2018 December 31 01:16:22 »
Hello PI team,

Unfortunately I have the very same issue:
In the beginning it worked all fine. But since about two days ago I do get the very same error message though when running SubframeSelector, and no graph is being displayed subsequently after analysis is done:
https://drive.google.com/file/d/1Z5slbRHuu-YXOStxszUPFu7ZCj3tzN07/view?usp=sharing

Mac OS X 10.13.6
Pixinsight Core 01.08.06.1448 Ripley (x86)

Thanks for looking into this
Stefan

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6481
    • View Profile
    • http://pixinsight.com/
Re: Subframeselector process : Graph Error : Invalid script execution
« Reply #2 on: 2019 January 02 02:32:06 »
This is a known problem with the SubframeSelector tool on Windows and macOS. I am working to fix it right now. It will be fixed very soon, either with a new version of PixInsight that I'm going to release or, if it delays a bit, with a regular update to the SFS module. Thank you for your patience.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline F83eric

  • Newcomer
  • Posts: 2
    • View Profile
Re: Subframeselector process : Graph Error : Invalid script execution
« Reply #3 on: 2019 January 03 09:26:53 »
Ok Juan, thank you for the news

If it helps I had the problem also on a new pc at first launch.

Eric

Offline pipplo

  • Newcomer
  • Posts: 2
    • View Profile
Re: Subframeselector process : Graph Error : Invalid script execution
« Reply #4 on: 2019 January 14 20:56:08 »
Is there any ETA on the fix release? Or maybe a temporary workaround in the meantime? SFS was working for a while before it stopped so I imagine there is something I can do to fix it manually?

Offline pipplo

  • Newcomer
  • Posts: 2
    • View Profile
Re: Subframeselector process : Graph Error : Invalid script execution
« Reply #5 on: 2019 January 14 21:37:34 »
I went through the pixinsightconfig file and deleted a bunch of ScriptData\SubFrameSelector settings, and just about anything else that seemed 'config' related for subframe selector and it's working now.