Author Topic: PixInsight 1.8.6 Error - CreateSpinBox(): Low-level API function error (0x0001)  (Read 870 times)

Offline amitk75

  • Newcomer
  • Posts: 6
    • View Profile
Hi,

I have installed 1.8.6 on my laptop today and every now and then I am getting this error:

*** PixInsight API Error: CreateSpinBox(): Low-level API function error (0x0001): Unknown error


This is happening when using different tools like ABE, DrizzleIntegration, STF, File Save, etc. So not for any particular operation. Tried restarting laptop but still the same. When I restart PI, it works for some time, and then again I start getting error.

OS: Windows 10
CPU: Core i7 Gen 3
RAM: 16 GB

Thanks,
Amit

Online Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6537
    • View Profile
    • http://pixinsight.com/
Hi Amit,

This is not reproducible on any of our working and testing machines. This does not happen under normal working conditions. On Windows, weird problems can happen because of defective or outdated graphics drivers. Check that you have the latest versions of your graphics drivers installed.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline amitk75

  • Newcomer
  • Posts: 6
    • View Profile
But it was working fine with old version till today morning. Never got any error. Only after installing new version I started getting this error. It may not be graphics related, sometimes it doesn't allow me to save file also.

Online Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6537
    • View Profile
    • http://pixinsight.com/
Quote
It may not be graphics related, sometimes it doesn't allow me to save file also.

This is indeed strange. However, I have seen truly spectacular problems caused by wrong graphics drivers; sometimes they look like magic.

Anyway, we cannot reproduce any of these problems. Please realize that we cannot understand and fix a nontrivial problem if we cannot reproduce it. If possible, install and run the application on a different machine.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline amitk75

  • Newcomer
  • Posts: 6
    • View Profile
One more frequent issue I am facing:

*** PCL Win32 System Exception: At address 00007FFF28915470 with exception code C0000005 :
Access violation: invalid memory read operation at address 0000000000000008

Online Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6537
    • View Profile
    • http://pixinsight.com/
Again, we cannot reproduce these problems. I'd recommend checking your computer to see if you have installed the latest Windows updates available, including the latest version of your graphics driver. Trying the application on a different machine can also be helpful to identify the source of these issues. Otherwise, please provide a data set and a sequence of operations to reproduce these problems consistently.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline amitk75

  • Newcomer
  • Posts: 6
    • View Profile
Thanks. If no one else has reported the issue, perhaps it has to do something with my configuration itself. I will check it. I checked the graphics driver and its up to date. So must be Windows issue.

Thanks for your help and sorry for the trouble!

Offline discardedastro

  • Newcomer
  • Posts: 3
    • View Profile
I'm also seeing the CreateSpinBox error, frequently enough to really annoy. I particularly frequently see it when saving, but a number of different functions can trigger the error box.

To assist in diagnostics, my configuration is:

PixInsight 1.8.6
Windows 10 Professional, latest updates as of 2018-01-19
NVIDIA 1070 with drivers at 417.35
PI scratch location default (on OS disk, a Samsung Evo 850)
Images and project stored on a SSHD (2TB Seagate)
There's nothing else on the PC that could cause Qt to get confused as far as I know.

It feels like a UI/Qt issue because the underlying operations clearly still work. For instance, trying to save a file fails and pops up this error box, whereas saving the project with associated images does not (and works, so is my current workaround - only a bit of a pain with dynamic processes). Also the error talking about a spinbox which I'm guessing is the QtSpinbox class.

I have also seen that system exception - though much more rarely. I was able to trigger it after seeing the spinbox error and opening the FITS Header dialog.

I'd estimate that currently I'm getting this five or six times in my normal end-to-end processing workflow, but where it kicks off seems completely random. I've tried to come up with a reproducible scenario and failed. If there's anything I can do to enable some diagnostic/debug logging I'd be happy to provide more details.

Offline amitk75

  • Newcomer
  • Posts: 6
    • View Profile
So looks like I am not the only one to get this issue!

Offline John_Gill

  • PixInsight Addict
  • ***
  • Posts: 242
    • View Profile
Hi,

I think you may have a fault in the compurer's RAM.  The error seems to indicate that certain bit(s) of information in memory is not what the Windows was expecting.

See if you can find a RAM memory tester application and run that, and see if there are any errors.

Good luck
John
APM 107/700 apo on CGX mount
ZWO Optics - Autoguiding
Canon 60Da & ZWO1600mm
... when there are no clouds ...

Offline amitk75

  • Newcomer
  • Posts: 6
    • View Profile
But the problem is coming with 1.8.6 and never had any issue with earlier versions. Also not for any other software. I feel something incompatible has happened in this version. I will try to install 1.8.5 and check.

Offline John_Gill

  • PixInsight Addict
  • ***
  • Posts: 242
    • View Profile
it could be that a different portion of RAM, that is faulty, is now being used and therefore the error appears.
APM 107/700 apo on CGX mount
ZWO Optics - Autoguiding
Canon 60Da & ZWO1600mm
... when there are no clouds ...

Offline Andres.Pozo

  • PTeam Member
  • PixInsight Padawan
  • ****
  • Posts: 869
    • View Profile
it could be that a different portion of RAM, that is faulty, is now being used and therefore the error appears.
This problem is not because a faulty RAM chip. It happens in too many different computers.
IMO, the problem most probably is (in this order) in Qt, graphic drivers or inside PI.

Andrés.

Offline msmythers

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1169
    • View Profile
    • astrobin
I wonder if this is more of an Intel type relationship issue but like Andres was saying QT, driver, PI. I run an older AMD based computer, No Intel Inside, no built in graphics on the motherboard or CPU and have never seen any of these issues. I also have only run Nvidia graphics cards. The computer that I use is also heavily multitasking while running PI doing other multimedia/web/HTPC stuff. Not a pristine, one use computer by any means.


Mike

Offline discardedastro

  • Newcomer
  • Posts: 3
    • View Profile
I've also seen similar errors when doing things with image windows (moving them etc) in case it helps:

*** PixInsight API Error: CreateImageWindow(): Low-level API function error (0x0001): Unknown error

Again, if there's anything I can do to improve on "unknown error" in an environment where this appears eminently reproducible, do say. I've run a memory test without issue.