Author Topic: Release 1.8.6 Repeating Crashes  (Read 865 times)

Offline Palmito

  • Newcomer
  • Posts: 8
    • View Profile
Re: Release 1.8.6 Repeating Crashes
« Reply #15 on: 2019 January 25 08:46:37 »
Hello!

I am running a Win10 64-bit, Intel i7 6700K, 64Gb RAM, GTX-1080-6GB, Samsung evo 960 SSD with a 256Gb pagefile. I have been running PixInsight 1.8.5 with no issues whatsoever apart occasional crash (once or twice in one year).

I am very sorry to say but I am encountering many issues with build 1448.

I am still using old subframeselector script and it crashes very often with the same error.
There are two types of crashes, one were PI just closes and one with the same message as others:
PCL Win32 System Exception
At address 00007FFF63495470 with exception code C0000005:
Access violation: invalid memory read operation at address 0000000000000008

Also after some time it seems all js files fail to run. Typical errors are like:
*** Error [000]: C:/Program Files/PixInsight/include/pjsr/NumericControl.jsh, line 153: Error: At address 00007FFAFD1A5470 with exception code C0000005 :
Access violation: invalid memory read operation at address 0000000000000008

I have uninstalled and reinstalled both pixinsight and my nvidia drivers (including clean install) and it didn't help.
I have tried running PI with QT rendering in both software and rasterized, unfortunately with no success. So I reverted back to opengl.
I noticed subframeselector started working good again after I freed some space on my ssd (had 100gb free and freed an additional 300gb). But it only worked for a day or two. When I reached 250gb free space issues occurred again. I freed another 150gb but it still fails.
PI temp folder is currently 135Gb, which seems a bit higher than running 1.8.5.

I have also often encountered the following issue: If I switch to anther window and let PI sit for a few minutes in the background doing nothing it very often crashes when switching back to it.

After using PI for sometime it slows down at some point. I especially notice it in DrizzleIntegration as it slows down by a factor of ~50 but I believe it is generalized. Also when this happens my process icons starts flickering. Most of the time restarting PI is sufficient to fix, but sometimes a reboot is required.
When a reboot is required I notice GUI refresh is very slow upon reopening.

Build 1457 crashes far more often for me, and no matter what I am doing, it is very painful as when it starts failing I cannot save my progress.

Message is now only printed in console (At address 00007FFF63495470 with exception code C0000005) rather than a message box. But the issue iust that after a minute or two PI becomes unresponsive and crashes.

I will conduct more testing on build 1457, I am sorry if I am reporting fixed issues.

Those issues seems quite random and I haven't been able to reproduce on demand. Though switching between windows and desktops while PI is processing seems to make it worse. And as being a developer myself I know this is the worst situation because you cannot reproduce and while you cant reproduce you cant fix...
My personal feeling (because of the flickering, the free space and the js script crashing when trying to set GUI field) is that it might have something to do with QT/GUI and the hard disk access. But its only a gut feeling, I got no strong evidence for that ;-)

Let me know if I can provide anything, I will be glad to help!


I still noticed a very good overhall perfomance improvement and I believe it is an excellent release. Looking forward for a new build :-)

Offline Palmito

  • Newcomer
  • Posts: 8
    • View Profile
Re: Release 1.8.6 Repeating Crashes
« Reply #16 on: 2019 January 31 06:44:16 »
Hello,


So after more thorough testing, as promised, here are my results:

1 - Subframe selector script crashes as often as for build 1448, however errors are now only printed to the console and not in a modal interrupting message box. I have this issue no matter the files I use (even ones that worked fine either with v1.8.5 or v1.8.6).
Sometimes it happens after 3 files have been measured, sometimes after hundreds. Sometimes it is only a single file, sometimes it is a bunch of them in a row or close to each other. I fail to find any pattern other than the more files you add to the list the more probable it will occur.
I am convinced it is not linked to the data, as sometimes a particular file will work sometimes it won't, but if you wish let me know and I'll be happy to provide you my files.
My tests were conducted prior the module update I noticed today. But as I am using the script I believe my tests should still be valid, unless there are any dependencies with the module. Please let me know, and I will re-conduct tests if needed.

2 - About general use it seems crashes happen especially when I use Star mask module several times (on a small image, details attached).
I have a difficult picture with nebulosity that gets picked up and I am doing trial and error with star mask parameters. So I end up generating a lot of new views (I close them as I generate new ones tho).
After sometime it systematically crashes on my setup with the same error I reported in my previous post (after maybe 20 or 30 star masks have been generated).
I notice it crashes when I try to move new star mask window and it doesn't (instead error is printed in console). If I try closing it, each time I try the same error gets printed on the console after about 10 tries PI shuts down non gracefully.
I found a workaround for this! I believe this might help you pinpoint the exact issue, and help others experiencing the issue...
Interestingly, if instead of left click, I right click on the close button it works. The faulty view is closed with no errors and I can resume work without having to restart PI.


3 - For the performance sudden drop, It is still present but I have measured it a bit more precisely. I would say the slow down factor is closer to 25 times rather than 50.
With build 1457 restarting PI is not sufficient as a workaround but a reboot works all the time.

4 - The bug about opening PI and letting it sit in the background leading to a crash has never occurred on build 1457.



I also wanted to share more information about my system/usage of PI:
A - In PI I make use of 3 workspaces and have tens of process icons on each of them.
Upon opening a project with only process icons and no images, each process dialog appears and disappears. Looking like flickering and is slow to open even-though I have it set on workspace 4 containing no process icons.
This might be normal or already happening in v1.8.5, sorry I don't remember. But I didn't want to discard any information that might help you.

B - In my last post I didn't precise that my SSD is an M.2 2TB drive.
It is partioned in two disks, one containing OS, and one PI data, temp folder and pagefile.
Maybe somehow it could have an impact.

C - I also forgot to precise that all my drives have been trimmed, error checked and have windows indexing disabled.

D - PI swap storage folder is not a system temporary folder.

E - My motherboard is an ASUS Z170 PRO GAMING with latest BIOS installed.




Please kindly let me know if I can provide further help.


Looking forward for your response.

Cheers.
« Last Edit: 2019 January 31 08:33:18 by Palmito »

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6480
    • View Profile
    • http://pixinsight.com/
Re: Release 1.8.6 Repeating Crashes
« Reply #17 on: 2019 February 01 00:55:03 »
Hi,

I am very sorry to know that PixInsight 1.8.6 is performing so badly for you. However, none of the issues you are reporting can be reproduced under normal working conditions on a variety of Linux distributions and desktops, macOS 10.11, 10.12 and 10.14, and Windows 10. In all of our tests, which include severe stress tests with many gigabytes of data, version 1.8.6.1457 is stable under normal working conditions on all supported platforms.

Unfortunately, If I can't reproduce a nontrivial problem, I am unable to understand and fix it. The kind of issues you are reporting are most likely being caused by hardware-specific conditions, faulty device drivers, wrong operating system components, or conflicts with installed software utilities running as background processes. Windows is intrinsically a problematic platform, mainly because of bad design principles, the vast variety of uncontrolled interactions between software and hardware components, the proliferation of malware and bloatware, and also, unfortunately, because of problematic and even buggy system updates.

Assuming the obvious fact that you want to continue using Windows, my only recommendation in such a situation is a complete, clean reinstall of Windows 10. Please don't install a vendor provided copy of Windows, but an original copy downloaded directly from Microsoft servers. Make sure you install up-to-date device drivers. Do not install any bloatware. Perform a minimal software configuration that you always should keep as pure as possible. This is more or less what we call normal working conditions.

Sorry for not having more constructive advice to offer.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline nytewind1

  • Newcomer
  • Posts: 1
    • View Profile
Re: Release 1.8.6 Repeating Crashes
« Reply #18 on: 2019 February 26 19:09:18 »
Palmito, you're not alone on this.  I too have been running into memory issues on 1.8.6 that were not present with 1.8.5.  Same type of error messages that you posted.  I'm using a high-end Windows 10 Pro system also.  Notably the issues occur when I end up using a process like PCC, StarMask or repeated process instances to a preview.  This may not be considered normal operation as I'm trying to perfect the usage of some of these processes and will repeat iterations for over thirty minutes or more.  At some point (and not repeatable) PI will report the crash error.  As there seems to be no apparent fix as this is difficult to pinpoint, my only workaround is to save the PI project often so I can recover after I shutdown the PI project instance that's failing.  This is not a show-stopper for me as I really enjoy the product but just an added nuisance.  Maybe it will work itself out with future updates.

Offline CCDer

  • Newcomer
  • Posts: 4
    • View Profile
Re: Release 1.8.6 Repeating Crashes
« Reply #19 on: 2019 March 14 12:11:59 »
I too get repeated crashes on W7 with 01.08.06.1457 after never seeing them on previous releases. My crashes always occur when I go to expand an options box and this can happen immediately after starting PixInsight. I most often see it with Image Integration when I expand Pixel Rejection (1). But if I change Scale Estimater from the default of "Iterative k-sigma..." to "Average absolute deviation..." then it does not happen.  Then if I change it back to "Iterative k-sigma..." it's still okay to open and close the Pixel Rejection(1).  The details are:

 Problem Event Name:   APPCRASH
  Application Name:   PixInsight.exe
  Application Version:   1.8.6.1457
  Application Timestamp:   5c472890
  Fault Module Name:   StackHash_34cf
  Fault Module Version:   6.1.7601.24358
  Fault Module Timestamp:   5c5e1dff
  Exception Code:   c0000374
  Exception Offset:   00000000000bf302
  OS Version:   6.1.7601.2.1.0.256.1
  Locale ID:   1033
  Additional Information 1:   34cf
  Additional Information 2:   34cf7b3675121a09fd72c5e6172c6f07
  Additional Information 3:   9e0c
  Additional Information 4:   9e0c6839d118692b0cb17798b34a9e74


Also the same crash happens with Pixmath when I expand the Destination options. The details are:
 Problem Event Name:   APPCRASH
  Application Name:   PixInsight.exe
  Application Version:   1.8.6.1457
  Application Timestamp:   5c472890
  Fault Module Name:   StackHash_ce1e
  Fault Module Version:   6.1.7601.24358
  Fault Module Timestamp:   5c5e1dff
  Exception Code:   c0000374
  Exception Offset:   00000000000bf302
  OS Version:   6.1.7601.2.1.0.256.1
  Locale ID:   1033
  Additional Information 1:   ce1e
  Additional Information 2:   ce1e0dbc49f315cc4a1a3875da369dd0
  Additional Information 3:   2bb2
  Additional Information 4:   2bb2b08292fcfa513ad09e3b24ef60e3

I'm running with W7 on a i7 6700 CPU with 16GB memory. It's a Shuttle DH110 computer.





Offline CCDer

  • Newcomer
  • Posts: 4
    • View Profile
Re: Release 1.8.6 Repeating Crashes
« Reply #20 on: 2019 March 14 12:29:46 »
I will also add that these crashes occur when running PI as the first process immediately after a clean reboot.

Offline CCDer

  • Newcomer
  • Posts: 4
    • View Profile
Re: Release 1.8.6 Repeating Crashes
« Reply #21 on: 2019 March 14 12:45:54 »
And in addition, Windows Memory Diagnostic shows no errors and I can successfully run image integrations and drizzle integrations of up to 660 images without issue if I work around these option window expansion issues.