Author Topic: Color is evading me  (Read 1631 times)

Offline speach

  • PixInsight Enthusiast
  • **
  • Posts: 78
    • View Profile
Re: Color is evading me
« Reply #15 on: 2018 October 10 17:49:07 »
No problem, that should be fine.

Now I need someone who is smart to explain what's happening in the center of this galaxy. I've done this type of quick sanity check processing on hundreds of images and have not seen this before. What I thought was a post processing clipping error with the jpg from earlier in the post is in the linear image. The steps I took are simply ABE with attention to not sampling in the galaxy or brighter stars. Then BN and CC using the normal preview method. This is where I ran into problems. When I applied an exaggerated color saturation, the center of the galaxy was the wrong color and the outer spirals were very green. I then decided to use the arms as my white reference and now the arms look more correct and the stars look fine but you can see the center is just odd and missing some green to balance to a more normal galaxy center. I've never seen this with a linear image so someone smart needs to look.

As far as overall color the image seems fine. Just a bit noisy but I've seen and taken much worse.


Mike

being to wonder if it's the camera? will try again, the same subject, with an unmodified camera 

Online pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4531
    • View Profile
Re: Color is evading me
« Reply #16 on: 2018 October 10 19:01:31 »
how were these images captured? what software? what file format?

rob

Offline ngc1535

  • PixInsight Old Hand
  • ****
  • Posts: 311
    • View Profile
Re: Color is evading me
« Reply #17 on: 2018 October 10 20:51:38 »
I have seen this before... it occurs when the bayer matrix assignment is not quite right. But this idea was shot down earlier. I am not certain of another explanation.
-adam

Offline msmythers

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1176
    • View Profile
    • astrobin
Re: Color is evading me
« Reply #18 on: 2018 October 11 04:27:36 »
Ok folks I had asked in a PM for the first and last Raw images of the capture. If there was a camera issue then it would show in those images also. So the process was the same as before except add in debayer at the beginning. So debayer, abe, bn, cc, cs. The colors are fine. The color of the galaxy is what I would expect. So now the question is what is happening between the raw images and the end of the stacking.

rob had asked about the capture software which is a very good question. For my own processing I only work with original raw images and do everything else in PI so for this point I'm unfamiliar with what could be happening. What are the steps for the image integrations being taken?

Mike

Offline speach

  • PixInsight Enthusiast
  • **
  • Posts: 78
    • View Profile
Re: Color is evading me
« Reply #19 on: 2018 October 11 09:23:51 »
how were these images captured? what software? what file format?

rob
Canon 1100d moded, Raw, CR2, file format APT capture software. After capture PI was the only software used.

Offline speach

  • PixInsight Enthusiast
  • **
  • Posts: 78
    • View Profile
Re: Color is evading me
« Reply #20 on: 2018 October 11 10:02:42 »
Ok folks I had asked in a PM for the first and last Raw images of the capture. If there was a camera issue then it would show in those images also. So the process was the same as before except add in debayer at the beginning. So debayer, abe, bn, cc, cs. The colors are fine. The color of the galaxy is what I would expect. So now the question is what is happening between the raw images and the end of the stacking.

rob had asked about the capture software which is a very good question. For my own processing I only work with original raw images and do everything else in PI so for this point I'm unfamiliar with what could be happening. What are the steps for the image integrations being taken?

Mike

Thanks for a your help copying your method and settings I get more or less the same image as you do. Now to go back and reprocess and compare step by step.

Offline speach

  • PixInsight Enthusiast
  • **
  • Posts: 78
    • View Profile
Re: Color is evading me
« Reply #21 on: 2018 October 11 12:07:27 »
Found the problem next question is why? Didn't think that Sub Script Selector wrote to the file it was just there to grade them.
1st pic just debayered 2nd after it went through Sub Script Selector

Offline msmythers

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1176
    • View Profile
    • astrobin
Re: Color is evading me
« Reply #22 on: 2018 October 11 12:52:53 »
Simon

Great picture of the Checkerboard Galaxy ;).

I don't know. I just ran a debayer RGB image and a non-debayered through the script. I then took the original of each and subtracted the approved image of each from the originals in PixelMath. The results for both was 0, no change in the images. :-\ Time for subframe selector gurus to speak.


Mike

Offline niteman1946

  • PixInsight Addict
  • ***
  • Posts: 220
    • View Profile
Re: Color is evading me
« Reply #23 on: 2018 October 12 05:07:45 »
Hi Speach (Simon),

I know this is trivial but have you tried shutting done PI and rebooting the computer?

Mark

Offline speach

  • PixInsight Enthusiast
  • **
  • Posts: 78
    • View Profile
Re: Color is evading me
« Reply #24 on: 2018 October 12 16:17:37 »
Hi Speach (Simon),

I know this is trivial but have you tried shutting done PI and rebooting the computer?

Mark

yep several times