Author Topic: Image Calib Refuses To Apply Dark  (Read 928 times)

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Image Calib Refuses To Apply Dark
« on: 2018 September 27 12:43:51 »
Been trying to get to the bottom of this for two days.  Gave up and did Preprocessing in CCDStack.  Acts as if the dark is ignored in PI.  Here are two screen shots of my settings.

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #1 on: 2018 September 27 12:45:50 »
Second screen shot:

Offline RickS

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1298
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #2 on: 2018 September 27 13:48:58 »
For a CMOS camera you probably want to turn off dark optimization.

Cheers,
Rick.

Offline sharkmelley

  • PTeam Member
  • PixInsight Addict
  • ***
  • Posts: 239
    • View Profile
    • Mark Shelley Astrophotography
Re: Image Calib Refuses To Apply Dark
« Reply #3 on: 2018 September 27 15:04:58 »
Quote from: Starcruiser
Second screen shot:

What makes you think the calibration refuses to apply the dark?
If I understand those screenshots correctly, scaling factors of around 0.94-0.95 are being applied to the dark.  That is almost 1.0 i.e. very similar to a straightforward subtraction of the whole dark.
The bit to look for in the Process Console or the log file is where it mentions the dark scaling factor:
e.g.
Dark scaling factors:
t0 = 0.939

Mark
Takahashi Epsilon 180ED
H-alpha modified Sony A7S
http://www.markshelley.co.uk/Astronomy/

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #4 on: 2018 September 28 08:52:04 »
Quote from: Starcruiser
Second screen shot:

What makes you think the calibration refuses to apply the dark?
If I understand those screenshots correctly, scaling factors of around 0.94-0.95 are being applied to the dark.  That is almost 1.0 i.e. very similar to a straightforward subtraction of the whole dark.
The bit to look for in the Process Console or the log file is where it mentions the dark scaling factor:
e.g.
Dark scaling factors:
t0 = 0.939

Mark

Because after calibration the subs are covered with the identical hot pixels which match up similarly to the dark master.  When calibrated in CCDStack this does not occur.  This behavior did not happen until after the first time I got this message a couple days ago: "** Warning: No correlation between the master dark and target frames" and those subs likewise were full of hot pixels as it is my understanding the master is ignored in such a case.

Now I don't get the warning and everything is as shown in my screen shots and the subs are not worth integrating after calibration.  Yes I see what you mentioned about the scaling factors being applied but the results sure don't show it.  After spending hours over two days doing this over and over I gave up and did the calibration in CCDStack.  I don't remember having this issue with PI in the past until now.

Thanks for your response.

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #5 on: 2018 September 28 08:53:20 »
For a CMOS camera you probably want to turn off dark optimization.

Cheers,
Rick.

Thanks but I tried that earlier in the game.  Did not fix any of this.

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4639
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #6 on: 2018 September 28 09:32:12 »
something must have changed - is it a new dark master you are working with?

no correlation means that IC scaled the dark down incrementally and repeatedly subtracted the scaled dark from the light, and found no minimum in noise. this usually happens when the lights are so short that they exhibit almost no dark signal. what is the duration relationship between the lights and dark in your case?

rob

Offline Enzo De Bernardini

  • PTeam Member
  • PixInsight Addict
  • ***
  • Posts: 274
  • Resistance is futile.
    • View Profile
    • Astronomí­a Sur
Re: Image Calib Refuses To Apply Dark
« Reply #7 on: 2018 September 28 09:54:28 »
Quote
Because after calibration the subs are covered with the identical hot pixels

Sometimes yes, but ImageIntegration (rejection algorithms) usually takes care of them. Try WinsorizedSigmaClipping.

HTH.

Best regards,

Enzo.

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #8 on: 2018 September 28 13:06:51 »
Quote
Because after calibration the subs are covered with the identical hot pixels

Sometimes yes, but ImageIntegration (rejection algorithms) usually takes care of them. Try WinsorizedSigmaClipping.

HTH.

Best regards,

Enzo.

Thanks, but thats what I have been using.

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #9 on: 2018 September 28 13:14:49 »
something must have changed - is it a new dark master you are working with?

no correlation means that IC scaled the dark down incrementally and repeatedly subtracted the scaled dark from the light, and found no minimum in noise. this usually happens when the lights are so short that they exhibit almost no dark signal. what is the duration relationship between the lights and dark in your case?

rob

Thanks.  I am using 10 min lights with 10 min darks.  Over two days I have made several new dark 10 min. masters, the problem only gets fixed in CCDStack for the calibration phase and extract the color channels.  After that I bring it all back over to PI so I can get something done on this job.  I am starting to wonder if something has gone sour with my ImageCalibration tool.

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 4639
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #10 on: 2018 September 28 14:09:51 »
well i suppose the only way to rule that out is if you post your calibration masters and a light and see what happens when someone else tries...

rob

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #11 on: 2018 September 29 14:17:07 »
Well my last ditch attempt as an experiment was to acquire all new -10C darks last night and make a fresh master from those and see how that goes running it on a group of just three lights and see of the problem is gone with ImageCalibration module.



Offline sharkmelley

  • PTeam Member
  • PixInsight Addict
  • ***
  • Posts: 239
    • View Profile
    • Mark Shelley Astrophotography
Re: Image Calib Refuses To Apply Dark
« Reply #12 on: 2018 September 29 16:09:07 »
Quote from: Starcruiser
Well my last ditch attempt as an experiment was to acquire all new -10C darks last night and make a fresh master from those and see how that goes running it on a group of just three lights and see of the problem is gone with ImageCalibration module.
And what was the result?
Were the lights at -10C?
Takahashi Epsilon 180ED
H-alpha modified Sony A7S
http://www.markshelley.co.uk/Astronomy/

Offline Starcruiser

  • Newcomer
  • Posts: 25
    • View Profile
Re: Image Calib Refuses To Apply Dark
« Reply #13 on: 2018 October 02 16:40:56 »
Quote from: Starcruiser
Well my last ditch attempt as an experiment was to acquire all new -10C darks last night and make a fresh master from those and see how that goes running it on a group of just three lights and see of the problem is gone with ImageCalibration module.
And what was the result?
Were the lights at -10C?

Hi, thanks for checking in.  Went ahead and reacquired a new set of -10C darks and bias, made the new masters from them and applied them to several of the earlier problematic -10C lights.  All appears to be in order.  Not sure what caused my earlier difficulties but we seem to be good to go.--Thanks.