Author Topic: Mosaic issues with "register/union separate"  (Read 157 times)

Offline armyortho

  • Newcomer
  • Posts: 14
    • View Profile
Mosaic issues with "register/union separate"
« on: 2018 August 12 22:51:55 »
Hello folks,

I'm making a 12 panel mosaic of Northern Cygnus.  Gonna be awesome.  My process is as spelled out in Light Vortex, but I am persistently running into one issue and I can't figure it out.

Each frame is 4096 x 4096 pixels.  4 across, 3 high.  Total pixel size of the resulting rough mosaic is 15910 x 12324.  When I go back into Register/Union Separate in preparation for GradientMergeMosaic, 11 of the 12 frames come out with those exact parameters (15190 x 12324), but one comes out 15190 x 12325.  It's off by a single pixel.  I'm using the same reference for all 12 images, and that reference is the rough mosaic at 15190 x 12324.  I have no clue where this extra pixel is coming from or what do to to prevent it from happening.  Because of that difference, GradientMergeMosaic errors out.

It's happened in the past, and the only way I could get rid of it was to delete everything, reprocess, and on my 3rd attempt, it worked out. 

I don't know if I have three more days of building this mosaic in me.  Any of you smarter folks around here have any clue what I'm doing wrong?

Online msmythers

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1069
    • View Profile
    • astrobin
Re: Mosaic issues with "register/union separate"
« Reply #1 on: 2018 August 12 23:46:20 »
I'm not sure why this is happening. It is possible to remove a row or rows of pixels with the Crop tool. I'm not sure if it would have any ill effect on your mosaic and it isn't finding out what is causing the problem but it might help.

Here is a screen shoot that show how if your unfamiliar with this part of the tool.


Mike

Offline pfile

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 3777
    • View Profile
Re: Mosaic issues with "register/union separate"
« Reply #2 on: 2018 August 13 04:58:34 »
that flow is kind of outdated... i would just plate solve each pane and then use MosaicByCoordinates to generate the input frames for GMM. much easier and takes all of the grunt work out of the process.

i also have had the "one pixel too many" problem from time to time and i am not sure what causes it.

rob

Offline armyortho

  • Newcomer
  • Posts: 14
    • View Profile
Re: Mosaic issues with "register/union separate"
« Reply #3 on: 2018 August 13 18:30:49 »
Oh, that sounds so much nicer.  I'll give that a shot when I get home.  Thanks so much.