Author Topic: Dark frame appears purely white in PI  (Read 146 times)

Offline hzimmer3

  • Newcomer
  • Posts: 2
    • View Profile
Dark frame appears purely white in PI
« on: 2018 May 17 07:58:33 »
I'm new to PixInsight and tried to run my first image calibration. I use a ZWOptical 1-color cooled ccd camera (ASI071 MC Pro) and took
a couple of dark frames with 300secs exposure. Upon opening the darks in PI they appear purely white, whereas in Maxim DL Pro as well
as in FitsWork they are black. The camera was cooled down to -20 C when acquiring the darks.

What am I doing wrong?  Any hint into the right direction is very much appreciated.

Thanks in Advance
Helmut
Cologne/Germany

Offline bulrichl

  • PixInsight Addict
  • ***
  • Posts: 228
    • View Profile
Re: Dark frame appears purely white in PI
« Reply #1 on: 2018 May 17 08:22:51 »
Hi Helmut,

probably the settings in 'Format Explorer/FITS' have to be adjusted to the number format of your acquisition software.

Bernd

Offline hzimmer3

  • Newcomer
  • Posts: 2
    • View Profile
Re: Dark frame appears purely white in PI
« Reply #2 on: 2018 May 18 08:43:30 »
Hello Bernd,
I had a look into Format Explorer/Fits but there is no entry "Number format". Under "Capabilities" there are a couple of entries like
"sample-format-unit8" or "sample-format-float32" which are set to true and which cannot be changed. The dark frame was acquired
using Maxim DL 6 Pro, it has 16-bit format and is RGGB-Bayer pattern. Opening the dark in Maxim gives correct display. Maxim statistics
window tells me minimum pixel is 65528, maximum is 65528, standard dev 0.
 :-\
Helmut
Cologne/Germany

Offline bulrichl

  • PixInsight Addict
  • ***
  • Posts: 228
    • View Profile
Re: Dark frame appears purely white in PI
« Reply #3 on: 2018 May 18 14:06:37 »
Hi Helmut,

Quote
I had a look into Format Explorer/Fits but there is no entry "Number format". Under "Capabilities" there are a couple of entries like
"sample-format-unit8" or "sample-format-float32" which are set to true and which cannot be changed.

Sure you can. In Format Explorer you have to double click on 'FITS' in order to open 'FITS Format Preferences'. Here you can specify the Floating point input range. I guess that's it.

By the way, raw CCD data are 16-bit unsigned integers and hence should be stored in that format (see ref. 1).

For a discussion of such problems see also:
1) https://pixinsight.com/forum/index.php?topic=3474.msg23959#msg23959
2) https://pixinsight.com/forum/index.php?topic=3433.msg23657#msg23657
(The search function of the forum will find some more hits.)

Bernd