Author Topic: Linux install: run error  (Read 507 times)

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Linux install: run error
« on: 2018 April 22 14:39:26 »
Hi,

Setup a new PC with Ubuntu 17.10, downloaded latest PI distro package for Linux and installed.  Everything went okay, but when I go to /bin and run Pixinsight I get this error message:

craig@LinuxBox1:/bin$ PixInsight
/opt/PixInsight/bin/PixInsight: /opt/PixInsight/bin/lib/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/x86_64-linux-gnu/libpng16.so.16)
/opt/PixInsight/bin/PixInsight: /opt/PixInsight/bin/lib/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by /usr/lib/x86_64-linux-gnu/libmirclient.so.9)

I thought I installed Zlib but maybe there is another problem.

Craig

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Re: Linux install: run error
« Reply #1 on: 2018 April 22 15:11:13 »
Doing some research on this I noticed a PI requirement:

PixInsight 1.8.5 for Linux requires a 64-bit Linux distribution with glibc version 2.17 (December 2012) or later and CXXABI_1.3.8 (GCC 4.9 or later).

I then found that libstdc++.so.6.0.21 so I tried to install:

root@LinuxBox1:~# apt-get install libstdc++.so.6.0.21
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libstdc++.so.6.0.21
E: Couldn't find any package by glob 'libstdc++.so.6.0.21'
E: Couldn't find any package by regex 'libstdc++.so.6.0.21'
root@LinuxBox1:~# apt-get install libstdc++6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libstdc++6 is already the newest version (7.2.0-8ubuntu3.2).
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
root@LinuxBox1:~#

so that didn't quite work, but it shows the latest version is installed.

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Re: Linux install: run error
« Reply #2 on: 2018 April 22 15:15:40 »
Glibc is 2.26

Offline RickS

  • PTeam Member
  • PixInsight Jedi
  • *****
  • Posts: 1295
    • View Profile
Re: Linux install: run error
« Reply #3 on: 2018 April 22 16:08:51 »
I had this error and the fix documented here worked for me: https://pixinsight.com/forum/index.php?topic=10718.msg73345#msg73345

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Re: Linux install: run error
« Reply #4 on: 2018 April 22 17:19:05 »
Worked perfectly .. maybe one of the PI team could add this to the Linux installation notes (troubleshooting section).
Thank you heaps for coming back quickly with this solution.

Craig