Author Topic: Aperture Photometry error posPx is null  (Read 797 times)

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Aperture Photometry error posPx is null
« on: 2018 January 01 15:54:19 »
Getting this error and am not sure what the problem is.  The log shows the image plate solved successfully, the script then downloads Vizier data from UCAC3 catalog, showing 3070 objects inside the image and 12,520 catalog stars, but then get the error:

*** Error: Failure to process image file 'F:/Temp/Image_300.000secs_00000520.fit': TypeError: posPx is null.

Craig

Offline Andres.Pozo

  • PTeam Member
  • PixInsight Padawan
  • ****
  • Posts: 894
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #1 on: 2018 January 02 02:43:34 »
I think I know how to fix this problem, but I would need your image in order to know why it fails.

Andrés.

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #2 on: 2018 January 02 09:43:53 »
Hi Andres,

I can upload the image to my FTP server if that helps, otherwise let me know if you prefer a different method.

Craig

Offline Andres.Pozo

  • PTeam Member
  • PixInsight Padawan
  • ****
  • Posts: 894
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #3 on: 2018 January 02 13:00:42 »
Hi Andres,

I can upload the image to my FTP server if that helps, otherwise let me know if you prefer a different method.

Craig
A FTP server is fine. Dropbox would also be ok.

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #4 on: 2018 January 02 15:46:20 »
Hi Andres,

I sent you a private message with the FTP details.

Craig

Offline Andres.Pozo

  • PTeam Member
  • PixInsight Padawan
  • ****
  • Posts: 894
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #5 on: 2018 January 03 12:04:33 »
I've created a pull request in GitHub with the fix of this problem.

Offline CraigNZ

  • PixInsight Enthusiast
  • **
  • Posts: 88
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #6 on: 2018 January 03 14:15:51 »
Hi Andres,

Thank you heaps for jumping on this and fixing it so quickly.

Is there anything I need to do, or just wait for PI to auto update?

Craig

Offline Andres.Pozo

  • PTeam Member
  • PixInsight Padawan
  • ****
  • Posts: 894
    • View Profile
Re: Aperture Photometry error posPx is null
« Reply #7 on: 2018 June 04 01:09:10 »
Juan has just published an update with the fix of this bug.