Author Topic: Test for Canon 'Dual Pixel Raw' CR2 Images and Display a Message  (Read 842 times)

Offline jimwaters

  • Member
  • *
  • Posts: 70
    • View Profile
The Diagnostic Script for the BatchPreprocessing Script needs to check for Canon ‘Dual Pixel Raw’ CR2 images.  If the Canon cameras have this turned ON an error message needs to be displayed.

See problem report at this link.
https://pixinsight.com/forum/index.php?topic=11672.0

Offline sharkmelley

  • PTeam Member
  • PixInsight Addict
  • ***
  • Posts: 234
    • View Profile
    • Mark Shelley Astrophotography
Re: Test for Canon 'Dual Pixel Raw' CR2 Images and Display a Message
« Reply #1 on: 2017 October 14 00:34:09 »
Which version of PixInisght are you using?

I picked up a 5D Mark IV dual-pixel raw file from here https://www.rawdigger.com/howtouse/Canon-dual-pixel-technology
It opened just fine in PI 1.8.5
What happens if you download and open the same image?

Are you using an older version of PI, which maybe has an older version of DCRaw, which potentially doesn't understand the raw format?

Mark
Takahashi Epsilon 180ED
H-alpha modified Sony A7S
http://www.markshelley.co.uk/Astronomy/

Offline jimwaters

  • Member
  • *
  • Posts: 70
    • View Profile
Re: Test for Canon 'Dual Pixel Raw' CR2 Images and Display a Message
« Reply #2 on: 2017 October 14 00:56:22 »
I am using the current version of PI.  I assume the DCRAW file is current too.  Since this problem went away when I retook the quick Flats with 'Dual Pixel Raw' turned off I feel its likely the problem.  The new Flats were about the same brightness.  Not sure it could be anything else.

I haven't tried just opening a Dual Pixel Raw CR2 file.  They are gone now.  I deleted them.