Author Topic: No CFA pattern after Cosmetic Correction  (Read 791 times)

Offline Luigi

  • PixInsight Addict
  • ***
  • Posts: 140
    • View Profile
No CFA pattern after Cosmetic Correction
« on: 2017 September 30 18:43:41 »
I calibrated my Nikon RAW (NEF) files in ImageCalibration (output of _c files).
I used the '_c' files as input to the CosmeticCorrection process.
When I debayer the '_cc' files, I get the error below. I *can*, however, debayer a '_c' file.

Did the CosmeticCorrection 'lose' the fact that my images are CFA?

I am on MacOS High Sierra, running the latest PI. Ideas?

---
Loading target file:
/Volumes/Images/Astronomy/Images/2017/0923-24 Veil/temp/cosmetic corrected lights/LIGHT_300s_200iso_6-3_20170923-22h53m33s820ms_c_cc.xisf
Loading image: w=6034 h=4028 n=1 Gray Float32

*** Error:
*** Error: Unable to acquire CFA pattern information: Unavailable or invalid image properties.
Regards,
Luigi Marchesi

Offline Raymond

  • Member
  • *
  • Posts: 55
    • View Profile
    • Astrophotography
Re: No CFA pattern after Cosmetic Correction
« Reply #1 on: 2017 September 30 20:21:08 »
Maybe you forgot to check the CFA-box?
Raymond

Planewave 14" CDK - 10Micron GM2000HPS
William Optics 110/770 & FF | HEQ5-Pro
Omegon 66/400 | MGEN-Lacerta
Canon 500d mod

Offline Luigi

  • PixInsight Addict
  • ***
  • Posts: 140
    • View Profile
Re: No CFA pattern after Cosmetic Correction
« Reply #2 on: 2017 October 01 08:25:57 »
I do have the CFA box checked. I am wondering if this is a regression introduced into CC, since I know I've used this process before. Or, I'm dense. One of those two :)

I uploaded a calibrated light and a cosmetically-corrected light to dropbox (and put a post in the 'Bug Report' forum)

https://www.dropbox.com/s/a57mfo1kc0i7wcf/LIGHT_300s_200iso_6-3_20170923-21h59m03s680ms_c.xisf?dl=0

https://www.dropbox.com/s/ar3u0i7yuhl72jj/LIGHT_300s_200iso_6-3_20170923-21h59m03s680ms_c_cc.xisf?dl=0
« Last Edit: 2017 October 01 08:51:21 by Luigi »
Regards,
Luigi Marchesi

Offline oldwexi

  • PixInsight Guru
  • ****
  • Posts: 623
    • View Profile
    • Astronomy Pages G.W.
Re: No CFA pattern after Cosmetic Correction
« Reply #3 on: 2017 October 01 10:15:53 »
Hi Luigi!
When you debayer the cc files instead of "Auto"
with "RGGB" evrything runs smooth without error message.

Gerald

Offline Luigi

  • PixInsight Addict
  • ***
  • Posts: 140
    • View Profile
Re: No CFA pattern after Cosmetic Correction
« Reply #4 on: 2017 October 02 16:32:06 »
Yes! That fixed it (not sure why I didn't think to try that myself). Thanks much!
Regards,
Luigi Marchesi