Author Topic: How to disable thumbnail opening?  (Read 797 times)

Offline FunTomas

  • PixInsight Addict
  • ***
  • Posts: 135
    • View Profile
    • Astrofoto.sk
How to disable thumbnail opening?
« on: 2017 September 11 12:19:06 »
When opening FITS file, embedded thumbnail is opening too. This causes error at Batch preprocessing scripts. Is it possible to remove thumbnail from image, or prevent open thumbnail?

Offline vogelito

  • Newcomer
  • Posts: 10
    • View Profile
Re: How to disable thumbnail opening?
« Reply #1 on: 2017 November 03 11:35:38 »
I'm also having this issue.  Any solutions or workarounds?

I used BatchFormatConversion to go from RAW to FITS, and this created the thumbnail.  There doesn't seem to be an Output format hint to stop thumbnail generation.

(I know, FITS is deprecated, but I want to use it so I can open files later in Matlab/Octave. And would rather not have extra intermediate conversion steps from .NEF to .XISF to .FITS if I can help it.)

Thanks

Offline vogelito

  • Newcomer
  • Posts: 10
    • View Profile
Re: How to disable thumbnail opening?
« Reply #2 on: 2017 November 03 12:02:38 »
I can do a batch open/save in the program ImageJ that will not save the thumbnail.  Also seems that ImageMagick could do the trick, although the output seems oddly scaled.

I'd still love to know if anyone has ideas within PI.  (This workflow won't be repeated often by me, so I don't mind the inconvenience for now.)

Thanks again.
Mike

Offline STAstro

  • Newcomer
  • Posts: 43
    • View Profile
Re: How to disable thumbnail opening?
« Reply #3 on: 2018 February 12 14:33:20 »
You can do this in Global Preferences under File I/O Settings, as well as when you save the file there's an option to generate the thumbnail

See attached

Regards
Simon