Author Topic: 1.8.5 Segment Violation  (Read 1123 times)

Offline slang

  • Member
  • *
  • Posts: 56
    • View Profile
1.8.5 Segment Violation
« on: 2017 August 07 06:33:22 »
Hey.

Am trying out 1.8.5 on Linux Mint 17.3. As per my preivous post, I've had to upgrade gcc (and a few other components) to 4.9 in order for the installer etc. to work.

I've had two seg violations tonight.

PixInsight 01.08.05.1352 - Critical Signal Backtrace
Signal : 11
Module : /opt/PixInsight/bin/PixInsight() [0x156068d]
========================================================================================================================
3: /lib/x86_64-linux-gnu/libpthread.so.0(+0x10330) [0x7fd56867a330]
2: /lib/x86_64-linux-gnu/libc.so.6(+0x155d14) [0x7fd55dd95d14]
1: /usr/lib/nvidia-340/libGL.so.1(+0xa42c6) [0x7fd55c14a2c6]
========================================================================================================================
terminate called after throwing an instance of 'pcl::EUnixSegmentationViolation'






PixInsight Core 01.08.05.1352 Ripley (x64)
Copyright (c) 2003-2017 Pleiades Astrophoto



PixInsight 01.08.05.1352 - Critical Signal Backtrace
Signal : 11
Module : /opt/PixInsight/bin/PixInsight() [0x156068d]
========================================================================================================================
3: /lib/x86_64-linux-gnu/libpthread.so.0(+0x10330) [0x7f15230a9330]
2: /lib/x86_64-linux-gnu/libc.so.6(+0x155d14) [0x7f15187c4d14]
1: /usr/lib/nvidia-340/libGL.so.1(+0xa42c6) [0x7f1516b792c6]
========================================================================================================================
terminate called after throwing an instance of 'pcl::EUnixSegmentationViolation'
/opt/PixInsight/bin/PixInsight.sh: line 35: 20055 Aborted                 /opt/PixInsight/bin/PixInsight

Wasn't doing the same things at all, not sure about the first, but the second I was trying out PCC.

Looking forward to throwing 70+ subs of sombrero at this, and trying some of the new features!

Cheers -
--
Mount: Orion Atlas 10 eq-g, GSO RC8, Astrophysics CCDT67
Guiding: ST80/QHY5L-II-M
Cam: Canon EOS 450D (IR Mod), QHY8L

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6646
    • View Profile
    • http://pixinsight.com/
Re: 1.8.5 Segment Violation
« Reply #1 on: 2017 August 07 06:46:06 »
Hi,

This is a crash of the OpenGL implementation installed on your Linux distribution. Please note that this has nothing to do with PixInsight; it's just that version 1.8.5 makes much more use of OpenGL operations than previous versions. If the OpenGL implementation crashes while PixInsight is running, the PixInsight core application also crashes as a result.

If your distribution has a faulty OpenGL implementation, you can run PixInsight with the --opengl=raster command-line argument. Say PixInsight --help for more information.

Let me know if this helps.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline jpaana

  • Newcomer
  • Posts: 12
    • View Profile
Re: 1.8.5 Segment Violation
« Reply #2 on: 2017 August 07 23:50:38 »
I also have OpenGL issues with running PixInsight on Ubuntu 17.04 over x2go remote desktop link. 1.8.4 works fine, but 1.8.5 gives error about too low GLX extension version even with --opengl=raster switch:

[5907:5935:0808/094412.741183:ERROR:gl_surface_qt.cpp(240)] GLX 1.3 or later is required.
[5907:5935:0808/094412.741242:ERROR:gl_surface_qt.cpp(370)] GLContextHelper::getEGLDisplay() failed.
QXcbConnection: XCB error: 172 (Unknown), sequence: 169, resource id: 174, major code: 149 (Unknown), minor code: 20
[5907:5935:0808/094414.177350:ERROR:gl_surface_qt.cpp(661)] Requested OpenGL implementation is not supported. Implementation: 0

I've got it working with NoMachine remote desktop, but would prefer x2go.

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6646
    • View Profile
    • http://pixinsight.com/
Re: 1.8.5 Segment Violation
« Reply #3 on: 2017 August 08 00:52:34 »
Unfortunately, even with --opengl=raster, there are some internal GUI elements that still depend on OpenGL. There's nothing I can do to remedy this; it's just how Qt works.

The error messages say it all: GLX 1.3 or later is required. Also keep in mind that we cannot test PixInsight on all existing Linux desktop managers and remote desktop managers. We can only cover the mainstream desktops, and even that is a big amount of work.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline slang

  • Member
  • *
  • Posts: 56
    • View Profile
Re: 1.8.5 Segment Violation
« Reply #4 on: 2017 August 16 04:31:31 »
Thanks Juan.

Have upgraded laptop and workstation to Mint 18.2, which includes GCC (et all) 4.9. Re-installed PI1.8.5 and all the updates.

Have also installed proprietary binary drivers for my Nvida card (on the desktop).

Have not had any problems so far either with installing or running on either system (although a lot of problems upgrading desktop to 18.2 - installer kept hanging...)

So far, it's looking great.

Cheers -
--
Mount: Orion Atlas 10 eq-g, GSO RC8, Astrophysics CCDT67
Guiding: ST80/QHY5L-II-M
Cam: Canon EOS 450D (IR Mod), QHY8L