Author Topic: Ubuntu 16.10+ support  (Read 1537 times)

Offline papaf

  • PixInsight Addict
  • ***
  • Posts: 182
    • View Profile
Ubuntu 16.10+ support
« on: 2016 November 04 06:28:42 »
Hi all,
PixInsight is unable to run on ubuntu rel. 16.10+ due to the drop of libgstreamer 0.10 release in favor of the 1.0.
I tried to get past it creating some simlinks, but it seems some libraries are simply missing from the new release, like libgstinterfaces.
Is it a big issue to use the new libgstreamer release?

Thanks

Offline papaf

  • PixInsight Addict
  • ***
  • Posts: 182
    • View Profile
Re: Ubuntu 16.10+ support
« Reply #1 on: 2016 November 14 05:39:27 »
If anybody has the same issue, it's solved rather simply by installing 2 packages directly from the 16.04 archive:

wget http://it.archive.ubuntu.com/ubuntu/pool/universe/g/gstreamer0.10/libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb
wget http://it.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_amd64.deb
sudo dpkg -i *deb

You can adjust the wget commands to use your local country ubuntu mirror.

Online Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6941
    • View Profile
    • http://pixinsight.com/
Re: Ubuntu 16.10+ support
« Reply #2 on: 2016 November 14 07:39:36 »
PixInsight works nicely on Ubuntu 16.04, so it is definitely able to run on it. It's just a matter of installing a couple of required packages, as you have discovered.

Quote
Is it a big issue to use the new libgstreamer release?

Yes, because Pixinsight must run on older Linux distributions. Our reference distribution is Red Hat Enterprise Linux 7.1.

On the other hand, including gstreamer in the standard PixInsight distribution archive is problematic, since this library has many and complex dependencies. I'll try to include it in the next version, though.
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline papaf

  • PixInsight Addict
  • ***
  • Posts: 182
    • View Profile
Re: Ubuntu 16.10+ support
« Reply #3 on: 2016 December 02 02:21:50 »
Thanks for your reply, Juan, but I wouldn't bother.

In my opinion, a workaround is perfectly fine for a Ubuntu non LTS release.