Version 1.8.8-6 Installation Error

reggiej42

Member
Apr 4, 2020
12
1
I got the following error when I installed the new PI version -

*** PixInsight API Error: Module: /Applications/PixInsight/bin/RAW-pxm.dylib

Cannot load library /Applications/PixInsight/bin/RAW-pxm.dylib: (dlopen(/Applications/PixInsight/bin/RAW-pxm.dylib, 6): Symbol not found: ____chkstk_darwin

Referenced from: /Applications/PixInsight/bin/RAW-pxm.dylib

Expected in: /usr/lib/libSystem.B.dylib

in /Applications/PixInsight/bin/RAW-pxm.dylib): Module load error

Any ideas?
 

pfile

PTeam Member
Nov 23, 2009
5,695
116
i think someone else reported this and they said they were on 10.13 (high sierra). are you on 10.13?

rob
 

pfile

PTeam Member
Nov 23, 2009
5,695
116
it appears that 10.13 was not explicitly targeted when juan built -6 but was not tested. from the announcement:

macOS 10.13 should be supported, but we no longer test the application on it so we cannot support it officially.
it looks like the only two modules which reference this symbol are RAW-pxm and StarNnet-pxm. StarNet you might be able to live without but if you want to open DSLR files you need libRAW.

idk if @Juan Conejero wants to fix this or not. it seems that somewhere in the build, 10.13 was not set as the development target.

i myself was running 10.13 until just a few weeks ago. if i hadn't upgraded i would have seen this while we were testing the release.

rob
 

reggiej42

Member
Apr 4, 2020
12
1
Thanks Rob. I went ahead and upgraded to Catalina and it looks like the problem went away. It only cost me a couple of hours of time.

Reggie
 

Walter

New member
Nov 6, 2016
1
0
Same Problem... unfortunately i can't update my iMac (Mid 2011) --> Catalina not supported :-(
 

pfile

PTeam Member
Nov 23, 2009
5,695
116
i think he can't since the tensorflow library and the libRaw library have this dependency rather than pixinsight itself. both are 3rd party pieces of code.

if you are really motivated you can use OpenCore to spoof a newer SMBIOS id and install mojave on your otherwise unsupported mac. i know there are people on the macrumors forum booting Big Sur on old mac pros, so an imac or whatever that's just a generation behind should work well.
 

Juan Conejero

PTeam Member
Sep 2, 2004
7,602
103
56
Valencia, Spain
pixinsight.com
I have the same problem. Would be great if @Juan Conejero could fix this. A lot of users still running macOS 10.13.
Unfortunately, the latest version 0.20.0 of LibRaw is not compatible with macOS 10.13 and older versions. Although the same happens with TensorFlow libraries, LibRaw is the actual showstopper here, at least for users working with DSLR cameras. Please understand that this is out of my control because the RAW format module depends on LibRaw, and I cannot modify it.