StarNet - new module for star removal

pfile

PTeam Member
Nov 23, 2009
5,709
116
yeah there's a chance it's just Mojave and Catalina but not 100% sure. anyway from the point of view of OSX it looks like someone is tampering with the PI binary when you try to install an unsigned module... so OSX prevents PI from loading the module. overall it's a good thing but in our case it turned out to be a hassle.

rob
 

tdgm

Well-known member
Nov 26, 2014
311
4
I might not know programing but I too have the most up to date Mac OSX Mojave and with PixInsight 1.8.8.4 everything works fine and StarNet Installs> It is when I install the NEW PixInsight 1.8.8.5 that the problem occurs (still on Mojave.

So the new PI has problems with an older Mac and also a newer Mac. So logic would presume that it is PixInsght not Mac that has changed.


Steve
 

pfile

PTeam Member
Nov 23, 2009
5,709
116
well no one actually said the problem was due to a change in OSX. the requirement for any dynamic library loaded by an application to be cryptographically signed by a valid apple developer is a compile-time option for applications.

the older versions of PI do not enforce this rule, but the newer versions do. that's all. that's why -4 and prior work and -5 (and presumably beyond) won't be able to load any third-party PI processes unless they were signed. i would sign it myself but i have to pay $100 so that apple will provide me with a certificate. since juan already has a developer certificate the most cost effective method is for him to sign the starnet dylib.

rob
 

eoverstreet

Member
Aug 4, 2015
16
1
I have reverted back to the prior version of PI .....and everything is as it should be - all scripts working!    Hopefully in the not to distant future the script can be loaded.
 

Johngm

New member
Aug 2, 2020
3
0
Hi Nikita,
I tried to install the module, but PI does not recognize it. I dowlnoaded the Starnet_PI folder and copied its contents into the folder C:\Program Files\PixInsight\bin.
I tried the command Install Module on the PI, the following messages appeared on a snall information window:

0 additional PixInsight module(s) were found on directory:
C:/Program Files/PixInsight/bin.

I'm running on windows 764 bits Ultimate up to date and with the last PI release.
Could you help me?

Thanks in advance for your support and best regards,
Sergio (Venice Italy)
Hi Sergio,

Ive just attached a new thread, because i am having the exact same issue. Did you ever resolve yours ?

John