Program not responding constantly

CRWPhoto

Member
Jun 4, 2015
16
0
I recently updated to the newest version of PI.  Everything works perfectly (and some things better) but I am always getting the "not responding" when the program computes something memory intensive.  Such as creating a star mask or saving a project.  By not responding I mean the entire screen goes opaque and the mouse pointer spins the blue circle.  Eventually it will work itself out and get back on track and I have not had the program actually crash or stay in that state of not responding... but it does  happen every single time I ask it to do something intensive. 

BTW- I'm running this on a machine with Intel i7-3840QM CPU and 32G of RAM and never had this problem with the previous version of PI.  Just wondering if this is a potential bug or is there a setting I can change somewhere that effects how resources are utilized. 

Thank you!
 

Attachments

John_Gill

Well-known member
May 6, 2016
421
3
62
Durban, South Africa
try this...Save your work/project and then go to "Edit" ---> "Global Preferences" ---> "Directories and Network" and make a note of the "Swap Storage Directories". Exit PixInsight and then using "File Explorer" navigate to the "Swap Storage Directories" and delete all the files. Now start PixInsight. Things might be a little slow as PixInsight has to re-cache everything, but it might fix the problem...

spaceisnotblack
John
 

millzey13

Active member
Mar 24, 2020
28
0
try this...Save your work/project and then go to "Edit" ---> "Global Preferences" ---> "Directories and Network" and make a note of the "Swap Storage Directories". Exit PixInsight and then using "File Explorer" navigate to the "Swap Storage Directories" and delete all the files. Now start PixInsight. Things might be a little slow as PixInsight has to re-cache everything, but it might fix the problem...

spaceisnotblack
John
Thank you John ill give this a shot. Clear skies