Process icon issue

tloebl

Well-known member
Jan 27, 2015
141
1
Running Mint Cinnamon and ran into an odd issue today. Not sure what I did, I may have tried to open a second instance of PI accidentally. In any case, all my process icons disappeared from the workspace but PI thinks they're still there. I tried downloading and rebuilding a new copy of PI with the same results. I wound up setting up a stack of new process icons in the workspace and saved them. Now if I open a new instance of PI I can read the new ones in just fine but if I try to read in any previous xpsm file, pi states " the present process icon set has been modified and is unsaved...unsaved. icons will be permanently lost. Throw away all process icons? Y/N" and will not open it. This is true even if I start a completely new instance and try to open one of the old icons. Wondering if this is a known issue. It was fun rebuilding all my process icons from scratch...


Tom
 

pfile

PTeam Member
Nov 23, 2009
5,220
57
loading a group of process icons is destructive, meaning, all process icons are closed and then the new ones are opened when you use "load...". this is what the warning message means.

if you want to load multiple sets of icons, you need to use the "merge process icons..." command. after starting up PI, you can load the first file with "load..", but all subsequent xpsm files need to be read in with "merge..."

rob