PI Instability on iMac

dgj9

New member
Feb 22, 2019
1
0
Hi. I am using PI version 1.8.8-5 Ripley (x64) on a 2017 iMac under Mojave. I have plenty of memory, and no known issues with the hardware.

Ever since upgrading to the latest version of PI, I have experienced many crashes under different circumstances. I will describe the two cases that have occurred today, the second being the one that occurs most frequently.

1. After loading on ongoing project, I tried to use Image Integration to integrate three images. One of these was a duplicate (as I only needed to integrate two images). After loading the images and clicking to begin the process, PI crashed. I was able to reproduce this behavior consistently. If I booted PI and tried integrating the three images without first loading the project, the integration was successful and the software did not crash. I tried resaving the project under a different name and rebooting, but the crash persisted. If, however, I loaded four images into Image Integration (two duplicates), the process completed successfully and PI did not crash.

2. On several occasions I have experienced a freeze-up of PI, requiring that I Force Quit the application. These occur when I try to load files into a process. The dialog window appears, I select the files to load, I click Open and the window freezes and the software becomes unresponsive. In the most recent case, I tried to load files into Image Integration. I think this has occurred with other processes. I am sorry I cannot be more specific. I will try to track this more closely. I note that on one occasion the dialog window froze for several minutes and then magically "unfroze" and loaded the image files. No idea what happened. There is no spinning beach ball when this freeze happens, and the Mac OS does not report that PI has become unresponsive even though it is.

I have attached a crash report for the crash described in item 1. There are no reports for the item 2 freeze behavior, unfortunately.

Thank you for any help you can provide.

Denis
 

Attachments

Juan Conejero

PTeam Member
Sep 2, 2004
7,402
67
56
Valencia, Spain
pixinsight.com
Hi Denis,

We cannot reproduce any of these problems on our working and testing macOS machines, and they haven't been reported before AFAIK. Currently we use macOS 10.15 Catalina exclusively on all of our development Mac machines, so other macOS versions, including 10.14 Mojave, are no longer supported officially by current versions of PixInsight (we still have to update the system requirements page to reflect this change).

Please provide a data set or a project where we can reproduce these problems. Otherwise they are machine-specific.