New in PixInsight 1.8.8-6: Gaia DR2 Local Database


Well-known member
Jul 28, 2020
So I must be doing something wrong, unless this setting is "sticky". I removed all the databases from Gia and APASS, for curiosity, and ran PCC again, and it was within seconds of the same amount of time. May I trouble you to see if you see a problem in my setup?


This setting takes the same amount of time as removing all the databases from gaia and apass and running it again. Unless that's a caching issue/benefit?


New member
Jan 2, 2016
Hello, I am reading the forum entries to install the Gaia DR2 catalog but for my case the proposed solutions do not work. I have no pending updates and my version of Px is 1887 running on Windows 10 64 bit. What I can do?

Goodnite Moon

Aug 25, 2020
I am trying to install the Gaia DR2 star catalog data into the process tool. I have the Gaia process tool installed and I can get to the preferences window just fine. So I have all that working fine.

The problem is that (besides that fact that I am not real computer savvy) when the file is downloaded I find a "*.tmp" file in the downloads folder. When I doulbe click on the filename I get this:


Where do I go from here? What is the checksums-sha256 file for and where should it go?

Do the Gaia files go into a specific folder? Should I create that folder?

Thanks in advance...


PTeam Member
Nov 23, 2009
i think the download didn't complete... the files should have .xpsd suffixes.

the sha256 file is just a listing of the sha-256 hashes of each .xpsd file in each star database section. a hash is sort of a short summary (a number) of some much longer piece of data that is hopefully unique for the given data. if you download the file and then perform the sha256 checksum on the download, the hash should match what's in the file. this is a way to check that what you downloaded is error-free. if you want to ignore this step, you can, if you believe that your browser has not corrupted the file while downloading it.


edit: should be "xpsd" not "xpsm"!
Last edited:

Goodnite Moon

Aug 25, 2020
Thanks for your quick response Rob.

I will see if i can get that corrected tonight. I will follow up with a report back.


Goodnite Moon

Aug 25, 2020
I successfully downloaded all 16 files. The real problem is that I was not waiting long enough for the file to download. Solution: I watched the Wi-Fi tab in Task Manager to watch the download progress.

Not having success with ImageSolver yet. I'll try to sort it out, if I am unsuccessful I'll be back. Thanks for your help Rob.

  • Like
Reactions: pfile

Goodnite Moon

Aug 25, 2020
ImageSolver is not working for me. I searched around the forum to see if anyone else has had a similar problem and discussed it here - no luck. Here is he log information when executing the ImageSolver script:

MultiscaleLinearTransform: Processing view: M31_RGB_LUM_Ha_Final_12x8_working
Starlet transform: done
Multiscale reconstruction: done
Normalizing sample values: done
1.114 s
Seed parameters for plate solving:
Center coordinates: RA = 00 42 44.330, Dec = +41 16 07.50
Resolution: 1.460 as/px

Starting StarAlignment iteration
Gaia: Global context
Executing Gaia DR2 search command...
3440 sources found.
95.182 ms
Catalog Gaia DR2 (XPSD): 3440 objects.

*** Error: Error: StarAlignment.noiseLayers(): numeric value out of range: 5

Please check the following items:
  • The initial coordinates should be inside the image.
  • The initial resolution should be within a factor of 2 from the correct value.
  • Adjust the star detection sensitivity parameter, so that the script can detect most of the stars in the image without mistaking noise for stars.
  • The catalog should be matched to the image. Choose the appropriate catalog and magnitude filter, so that the number of stars extracted from the catalog can be similar to the number of stars detected in the image.

*** Error: Unable to plate solve image: Alignment failed.

This usually happens because the initial parameters are too far from the actual metadata of the image.

Here's the dropbox link to the image (.tif format):

Last edited:

Juan Conejero

PixInsight Staff
Sep 2, 2004
Valencia, Spain
This image can be solved without any problems. Just run ImageSolver, search for M31 to get approximate center coordinates, and write something reasonable for focal length, pixel size and acquisition date. Enable distortion correction. You can see the parameters I've used, the astrometric solution and an annotated version below.


Referentiation matrix (world[ra,dec] = matrix * image[x,y]):
+4.33950013e-04  -3.93026520e-04  -4.51003771e-01
+3.92830906e-04  +4.33955609e-04  -1.82969109e+00
WCS transformation ....... Thin plate spline
Control points ........... 4292
Spline lengths ........... l:2382 b:2641 X:1474 Y:1804
Projection ............... Gnomonic
Projection origin ........ [2669.423296 1799.859470] px -> [RA:  0 42 44.942  Dec: +41 14 29.17]
Resolution ............... 2.107 arcsec/px
Rotation ................. 137.834 deg
Observation start time ... 2021-01-01 12:00:00 UTC
Focal distance ........... 489.36 mm
Pixel size ............... 5.00 um
Field of view ............ 3d 7' 34.0" x 2d 6' 27.0"
Image center ............. RA:  0 42 44.923  Dec: +41 14 29.17  ex: -0.028926 px  ey: +0.080009 px
Image bounds:
   top-left .............. RA:  0 40 25.344  Dec: +39 25 08.86  ex: +0.022736 px  ey: -0.013392 px
   top-right ............. RA:  0 52 40.676  Dec: +41 28 52.93  ex: +0.009617 px  ey: +0.024303 px
   bottom-left ........... RA:  0 32 54.467  Dec: +40 56 53.92  ex: +0.025734 px  ey: -0.030070 px
   bottom-right .......... RA:  0 45 12.997  Dec: +43 03 51.53  ex: -0.047574 px  ey: +0.140455 px

Goodnite Moon

Aug 25, 2020
Thanks Juan your help is appreciated.

I used the same settings that you suggested and it worked just fine. For those reading this thread in the future I also executed a reset to factory-default settings. This may or may not have been part of the solution.

I would like to congratulate you on having a great product. There is so much to learn and yes it can be frustrating but the end product is incredibly satisfying.

The FOV that I really wanted to annotate was an image that of the M81-M82 that I recently captured and processed. That was successful too. Annotating this FOV let's the mind go wild as 46 galaxies are revealed where a few of the identified galaxies are merely small edge on disks.

Thanks again to Rob and Juan!


Well-known member
Feb 20, 2013
Just a note in a bottle to anyone who passes by this thread, I am here for a second time since it looks like I had to reinstall the databases with the 1.8.8 version of PI. Funny seemed to work, then stopped and I went back here and reinstalled the databases.... duh.


Well-known member
Jun 22, 2020
I want to make sure I've downloaded the latest database, but this is what I'm seeing when I open Preferences for both the APASS and GAIA database. There don't appear to be any database files present and no options to download them. What does this mean?



Well-known member
Apr 17, 2019
Wells, Somerset, UK
You need to click on "select", and then navigate to the folder where you have downloaded the database files and select the required files. This does seem a bit inconsistent with terminology elsewhere (I would have expected "Add", not "Select").


Well-known member
Jun 22, 2020
You need to click on "select", and then navigate to the folder where you have downloaded the database files and select the required files. This does seem a bit inconsistent with terminology elsewhere (I would have expected "Add", not "Select").
Thanks, Fred.