Narrowband Calibration Problem

Phil Swift

Member
Apr 28, 2021
12
0
I have been using Pixinsight for almost 2 years and have taken many NB images using my ED 80 on HEQ5Pro mount. I took a batch of Ha subs last week and and tried to calibrate them today. I always run the Image Calibration with the same settings with Master Bias, Dark and Flat.

The calibrated images I am getting are almost totally black with a handful of stars and no nebulosity.

I ran some LRGB subs and these were fine also some older NB subs. The LRGB were all fine but the NB were all Black as described above.

I have checked all the original subs (fits files) and they look fine.

I have checked all the fits headers and they are fine.

I don’t think I have changed anything in my process.

Has something changed in Pixinsight or or is it me???
 

bulrichl

PTeam Member
Nov 2, 2016
1,095
134
La Palma, Canary Islands
I am not aware that the ImageCalibration process changed lately. Please post some details about your camera, the statistics of the Ha frames and the master calibration files, and about the calibration settings:

Which camera model are you using?
Please disclose the gain and offset settings and post the median values of a typical Ha frame, of the MasterDark and the MasterBias.
Do you calibrate manually or do you use WBPP?

If you calibrate manually:
How do you generate the MasterDark?
Please show your settings for the calibration of the light frames.

If you use WBPP:
Show the Control Panel with the MasterDark selected.

Bernd
 

bulrichl

PTeam Member
Nov 2, 2016
1,095
134
La Palma, Canary Islands
Hi Phil,

thank you for the detailed information.

Your approach of generating MasterBias and MasterDark is correct. I assume that you are using a MasterDark that is built from darks with an exposure time that matches the light frames.

Because of the "amplifier glow" of the ASI1600 it is not recommendable to use dark frame optimization in the calibration of the light frames. Please try the following settings:

- Disable the section 'MasterBias'
- Enable the section 'MaterDark', select the MasterDark, disable both options 'Calibrate' and 'Optimize'

Your settings in the section 'MasterFlat' are correct when the individual flat frames have been calibrated with the MasterBias and the calibrated flat frames have been integrated to the MasterFlat.

Please try the calibration of only a few Ha frames with the new settings. Probably this will not solve the problem of clipping, though. I suppose that the clipping is due to little signal in the Ha frames, because the filter absorbs strongly.

If clipping continues to be a problem with the new calibration settings, please try additionally the application of an output pedestal in the 'Output files' section of the ImageCalibration process. Usually a value of 100 to 200 DN will suffice.

After image calibration, please check the calibrated frames:
- inspect the histogram at a horizontal zoom of about 50 to 100 and
- take a look at the statistics with option 'Unclipped' unchecked (this is the default). Count (%) should be > 99.9 %. The value (100 % - count (%)) is the fraction of clipped pixels.

When you integrate the calibrated and registered Ha frames, make sure that the option 'Subtract pedestals' is unchecked (this is the default).

I hope this will help.

Bernd
 

Phil Swift

Member
Apr 28, 2021
12
0
Hi Phil,

thank you for the detailed information.

Your approach of generating MasterBias and MasterDark is correct. I assume that you are using a MasterDark that is built from darks with an exposure time that matches the light frames.

Because of the "amplifier glow" of the ASI1600 it is not recommendable to use dark frame optimization in the calibration of the light frames. Please try the following settings:

- Disable the section 'MasterBias'
- Enable the section 'MaterDark', select the MasterDark, disable both options 'Calibrate' and 'Optimize'

Your settings in the section 'MasterFlat' are correct when the individual flat frames have been calibrated with the MasterBias and the calibrated flat frames have been integrated to the MasterFlat.

Please try the calibration of only a few Ha frames with the new settings. Probably this will not solve the problem of clipping, though. I suppose that the clipping is due to little signal in the Ha frames, because the filter absorbs strongly.

If clipping continues to be a problem with the new calibration settings, please try additionally the application of an output pedestal in the 'Output files' section of the ImageCalibration process. Usually a value of 100 to 200 DN will suffice.

After image calibration, please check the calibrated frames:
- inspect the histogram at a horizontal zoom of about 50 to 100 and
- take a look at the statistics with option 'Unclipped' unchecked (this is the default). Count (%) should be > 99.9 %. The value (100 % - count (%)) is the fraction of clipped pixels.

When you integrate the calibrated and registered Ha frames, make sure that the option 'Subtract pedestals' is unchecked (this is the default).

I hope this will help.

Bernd
Hi Bernd,
Thanks for the info, it worked in part.
I have been playing with the settings today and found some that work with all but one set of NB images I have taken recently. I cant find any difference in the set that don't work, all capture settings and FITS headers are the same. The originals look fine but when calibrated look all black. I think it must be something I've done but no idea what. All my other data from recent weeks seem to work with these settings now.

I found tht the Pedestal setting was not doing much unless I had it at around 500 and then producing very grainy images so set back to zero.
I have turned of the Bias settings
Checked Calibrate Dark and Optimize dark
These changes from the image I posted seem to give a good result.

However, If I am not using the Bias frames in Calibration should I be using Dark Flats or something else?

Regards
Phil
 

bulrichl

PTeam Member
Nov 2, 2016
1,095
134
La Palma, Canary Islands
If you are willing to provide the problematic light frames, the MasterDark, MasterFlat and either MasterBias or MasterFlatDark (upload them to a filehoster and post the link here), I will look into it.

Bernd
 

Phil Swift

Member
Apr 28, 2021
12
0
Hi Bernd,
I have put the Ha files that don't seem to calibrate properly and the Master Dark, Flat and Bias that I am using in this Dropbox folder.
Let me know if you can access them OK.
 

bulrichl

PTeam Member
Nov 2, 2016
1,095
134
La Palma, Canary Islands
No, Dropbox asks me to sign in to my Dropbox account. When I sign in (with my email address and Dropbox password), the error message "The folder /Bernd does not exist. " appears.
 

fredvanner

Well-known member
Apr 17, 2019
1,437
214
70
Wells, Somerset, UK
OK. Both the master bias and master dark have significantly higher signal levels (look at Statistics) than the light subs - they do not match!
Could you post one or two raw subs for the bias, and dark - it might be easier to see what has happened.
... it would also be a good idea to post one or two raw flats and dark flats, just in case they are also mismatched.
 
Last edited:

fredvanner

Well-known member
Apr 17, 2019
1,437
214
70
Wells, Somerset, UK
There doesn't appear to be anything wrong with the light subs, they just have a much lower bias (~900ADU) compared with the master bias (~1574ADU). Short of a change of gain setting, I can't think what could cause this.