Metadata error message - channel combination

dpaul

Well-known member
Jul 12, 2017
134
1
Hi,
I'm using a mono CMOS camera with L, R, G and B filters. Recently when forming an RGB image using Channel Combination, I'm getting this error message:
** Warning: Inconsistent Instrument:Filter:Name (FILTER keyword) value(s) - metadata not generated.
The process is working and colours are all fine so there doesn't appear to be any actual problem - why am I seeing this?
I've been doing this for 2 years and never saw this error until this week.
Thanks
David
 

pfile

PTeam Member
Nov 23, 2009
5,689
116
it must be new - i hadn't noticed this. but all it's saying is that there are 3 input images and 1 output image; the 3 input images have different values in the FILTER keyword which can't be merged into a single keyword for the RGB image. of course that doesn't make sense anyway. given the object oriented code in PI this might just be a side effect of code that tries to merge keywords even though it doesn't strictly make sense here.

rob
 

dpaul

Well-known member
Jul 12, 2017
134
1
Thanks Rob,
It would useful to know why its started happening. Just for interest, I just tried it on something I did two years ago and the very same message came up.

FYI - I'm currently using version of 1.8.8-5 of PI but I believe there is a new one out, correct? I only recently changed from an earlier one and then it now says 'change again'.
 

pfile

PTeam Member
Nov 23, 2009
5,689
116
yes there is a new core out, 1.8.8-6. there's an announcement thread in the forum. i guess i assumed you were already on that version and that might have accounted for the change.