Image Star Alignment - Error

groberts

Member
Dec 22, 2015
12
0
Assisted by the Light Vortex tutorial + after some wobbles, I successfully managed to integrate (stack) a set of LRGBHa subs for the first time, which looked OK when stretched. I've now moved onto the next step of alignment of the said images for subsequent combination in StarAlignment which on processing gives the the message:

*** Error: Variant::ToDouble(): Invalid conversion from ByteVector type

<* failed *>


Any thoughts on what's wrong?

I suspect the problem might be file type. On completing the aforemention stacking out of habit from DSS I thought I'd saved the finished stacks as Tiff files but I now see they were FITS - obvioulsy not paying attention. Strangely I can't see the output file typein settings but suspect that if it's still PI .xisf this could be a conflict? Below are the settings used and a full screen grab of the error.

Graham

StarAlignment: Global context

Loading reference image:

C:/Users/Graham/Desktop/PixInsight Image Tests/M101 March 2019/Stack2d/L Stack2d.fit

Reading FITS image: 32-bit floating point, 1 channel(s), 9312x7040 pixels: done

BLOB property extracted: 'Instrument:Camera:Gain', 8 bytes.

BLOB property extracted: 'Instrument:Camera:Name', 28 bytes.

BLOB property extracted: 'Instrument:Camera:XBinning', 4 bytes.

BLOB property extracted: 'Instrument:Camera:YBinning', 4 bytes.

BLOB property extracted: 'Instrument:Filter:Name', 2 bytes.

BLOB property extracted: 'Instrument:Sensor:XPixelSize', 8 bytes.

BLOB property extracted: 'Instrument:Sensor:YPixelSize', 8 bytes.

BLOB property extracted: 'Instrument:Telescope:FocalLength', 8 bytes.

BLOB property extracted: 'Instrument:Telescope:Name', 24 bytes.

BLOB property extracted: 'Observation:Center:Dec', 8 bytes.

BLOB property extracted: 'Observation:Center:RA', 8 bytes.

BLOB property extracted: 'Observation:Equinox', 8 bytes.

BLOB property extracted: 'Observation:Location:Latitude', 8 bytes.

BLOB property extracted: 'Observation:Location:Longitude', 8 bytes.

BLOB property extracted: 'Observation:Object:Name', 8 bytes.

BLOB property extracted: 'Observation:Time:End', 12 bytes.




BLOB property extracted: 'Observation:Time:Start', 12 bytes.

63 FITS keywords extracted.

*** Error: Variant::ToDouble(): Invalid conversion from ByteVector type

<* failed *>
 

Attachments

groberts

Member
Dec 22, 2015
12
0
I'm still struggling to get round this problem and would appreciate help please.

Finding a similar thread I tried a file format conversion to .xisf but still get the same original problem.

 

ngc1535

Well-known member
Feb 1, 2014
467
45
Did you try turning off the generation of Drizzle data? (You do not need this.)
Make the files available?
-adam
 

ngc1535

Well-known member
Feb 1, 2014
467
45
Yeah... so, seems like making the file available is the only way to proceed.
-adam
 

ngc1535

Well-known member
Feb 1, 2014
467
45
If you make the files available for download, someone can check them out.
-adam
 

groberts

Member
Dec 22, 2015
12
0
Ah OK thanks but the files are ernormous and won't load (+250Mb) - I wonder if that's part of the problem?

I've just downloaded these stacks into PI again which on the face of it went OK but gave the following warnings:

**Warning: Variant::ToDouble(): Invalid conversion from ByteVector type

and

Warning Deprecated format: FITS

This seems to clearly indicate there's something wrong with the said files but what is it? These were created in PI and then manually saved after registration - did I do something wrong in the saving process perhaps?
 
Last edited:

WillB

Active member
Feb 20, 2015
43
5
Graham

Use a free file share account such as Google Drive to share large files sets.

Upload the files to the service and post a share link back here that anyone can follow to download your files.

From a Windows PC use the 'Send To' option and choose 'Compressed folder' to zip-compress and reduce the size of the the files to a folder on your desktop before you upload the compressed folder to Google Drive, otherwise they will take forever to upload from a standard asymmetric home broadband connection.

I use both Dropbox and Google Drive file sharing but Dropbox (free) only has a 2gb upload limit so for this image set you would be better off with Google Drive which has a larger capacity free-of-charge allowance.

William.
 

WillB

Active member
Feb 20, 2015
43
5
Graham.

You are almost there....but not quite.

In Google Drive, when you click on the folder you want to share and 'Get link' there is a further option to select before clicking the 'Copy link' shortcut, either 'Restricted' or 'Anyone with the link'.

Restricted is the default option.

You need to click on the option 'Anyone with the link', the hyperlink will change to a green colour, click on the 'copy link' to copy into clipboard and then paste that link back here.

The link you have posted above is a 'Restricted' link which means only someone who's name or ID you have added to the allowed list can download the file, you need to generate an open link that anyone can use.

An unrestricted link only applies to that file or folder, whatever else is in the Google Drive remains private.

William.
 

WillB

Active member
Feb 20, 2015
43
5
Graham.

That worked.

The problem is as you suspected, the .fit format is too restricted for advanced processing techniques and Star Alignment does not handle drizzle integrated images in .fit format in the latest PI platform.

This wasn't the case with earlier PI platforms and if you are following older tutorials they won't always point this out.

In general the authors of PI don't consider .fit to be a suitable format for advanced processing techniques and the platform doesn't really support .fit except to import raw or export completed images.

The error message is rather vague and unhelpful but that is the cause.

You can import the raw data as .fit or pretty much any other image format but once you are into advanced processing you should only use .xisf until the completion of all the processing stages.

Once the image has been successfully processed you can export as .fit or any of the other standard formats.

There was a previous question on the same error earlier this year and that was the reason given by Juan to that questioner.


Sorry to be the bearer of unwanted news but the only way forward is to start again and stick to .xisf throughout the process.

If possible, try to carry out the whole processing sequence in PI. It's not good practice to mix-and-match software during data processing as it makes it much more difficult to pin down where something went wrong in the sequence.

HTH

William.
 

groberts

Member
Dec 22, 2015
12
0
Many thanks for your time and help William, much appreciated. It's good to know there's a logical answer that can be dealt with and am
already back to reprocessing and saving as .xisf = all is not lost + on a positive note I learned something about Google Drive too!

Can't think what even made me save as FITs in the first place, more likely TIFF which is what I'm accustomed to in DSS - but I presume that might also be a problem in PI?

Regards, Graham
 

WillB

Active member
Feb 20, 2015
43
5
Can't think what even made me save as FITs in the first place, more likely TIFF which is what I'm accustomed to in DSS - but I presume that might also be a problem in PI?

Regards, Graham
Graham.

TIFF and other graphics image formats such as .png or jpg etc are really only suitable for use in general purpose image processing applications such as Photoshop for publication or printing.

.xisf is a standard developed for science imaging that stores image evaluation metrics with the image for use in the PixInsight tools and processes as well as the processing history and source .fits header data.

For good data sets that I may want to revisit I usually keep the original source data in .fits format, the calibrated masters and final image as .xisf. All the intermediate .xisf files are deleted once processing is complete.

I would only use TIFF/PNG for adding to a photo album or posting in a webpage.

William.
 
  • Like
Reactions: groberts