How to update the Normalize Scale Gradient Script

dhanford

Active member
May 8, 2020
42
0
I am trying to update the normalize scale gradient script. I installed PI version 1.8.8-8 but my version of NSG does not have the Image Integration features. With Windows do I need to uninstall PI altogether again and then re-install it? Or is there an update that I can download and install that will have the ImageIntegration features?
-Scott
 

jmurphy

PTeam Member
Jun 13, 2010
306
141
Basingstoke, England
PixInsight should check for updates when it first starts.
You can force it to check:
RESOURCES -> Updates -> Check for Updates.
If it finds updates, you will need to exit from PixInsight. The update will then install.
 
Last edited:

Kjearwattanakanok

New member
Mar 13, 2019
2
0
I found this error message after update "** Error: *** Error: /Applications/PixInsight/src/scripts/JohnMurphy/NormalizeScaleGradient/NormalizeScaleGradient.js, line 37: include file not found: lib/LeastSquareFit.js"
How to fix it?
Kijja
 

jmurphy

PTeam Member
Jun 13, 2010
306
141
Basingstoke, England
Sounds like some files are missing.
You can download NormalizeScaleGradient 1.1.a from here:
This version also adds "ALTITUDE" to the list of FITS headers used to read the altitude from.
 
Last edited:
  • Like
Reactions: Kjearwattanakanok

Kjearwattanakanok

New member
Mar 13, 2019
2
0
Sounds like some files are missing.
You can download NormalizeScaleGradient from here:
Problem solved! Thank you very much