Calibration of flats with dark flats - not matching flats with dark flats

gregk

New member
Sep 19, 2020
4
1
Hi, I'm having an issue calibrating my flats with dark. The problem is only occuring with my OIII data. Flats and Dark Flats for Ha and SII are fine but I'm getting the following message on the OIII:

** Warning: Neither master bias nor master dark found to calibrate Flat frames (filter = OIII, binning = 1, exposure = 11.75s, length = 50)

The exposure times and all other details are the same for the dark flats and flats (11.75s) and the other FITS header data all matches.

I've taken new flats and dark flats (slightly different times) and I'm still getting the same message.

The calibration files were taken using the flat wizard in NINA.

Any ideas?

Thanks

Greg
 

gregk

New member
Sep 19, 2020
4
1
Just to add, if I add the OIII lights, darks, flats and dark flats to WBPP on their own, there is no error message and the process runs with no errors.

So it's only when I try and process the narrowband files in one lot that WBPP gives the error message of not being able to match the flats with the dark flats for the OIII files.

Really weird.
 

ngc1535

PixInsight Ambassador
Feb 1, 2014
655
106
AdamBlockStudios.com
Hi Greg,

Can you post screenshots of the darks and flats tabs in WBPP?
Also, can you copy (or screen capture) The FITs header information of the OIII dark and the OIII flat showing the Exposure keyword?

-adam
 

atacamastar

New member
Mar 27, 2020
4
1
I am having the same issue - I also use the N.I.N.A. flats wizard. The file names and FITS headers for both the flats and the dark flats show matching times but WBPP does not recognize that info when processing the subs - screenshots attached
 

Attachments

atacamastar

New member
Mar 27, 2020
4
1

pfile

PTeam Member
Nov 23, 2009
6,170
180
which exposure tolerance control was the right one? i was going to suggest that but i was not sure which one was appropriate to change in this instance.

thanks

rob
 

atacamastar

New member
Mar 27, 2020
4
1
The "correct" technical answer is to reduce the exposure tolerance to the smallest whole number that is less than or equal to the least difference between your exposures -- so if your exposures are 6, 8, and 13, the tolerance setting should be 2. For practical purposes, I am just leaving the tolerance at 0 so I won't have to mess with it ever again. One cool thing is if your tolerance is set too high and you are getting the groupings shown in my screenshots, once you start adjusting the tolerance setting downwards, the groupings will start to "ungroup" as the settings move towards the correct setting. It is a way to test your exposure tolerance setting "on the fly" if you will.
 
Last edited:

pfile

PTeam Member
Nov 23, 2009
6,170
180
well i guess i meant that there is an exposure tolerance control for darks and lights, but not flats. i assume you are adjusting the tolerance for the darks?
 

atacamastar

New member
Mar 27, 2020
4
1
I was making a master set of flats and I was adjusting the exposure tolerance for the flat darks that went with the flats.
 
  • Like
Reactions: pfile