api-ms-win-core-libraryloader-l1-2-2.dll missing

Frank

New member
May 13, 2009
1
0
Just downloaded and attempted to install 1.8.8.3 for windows x64 and got this error when launching the program "api-ms-win-core-libraryloader-l1-2-2.dll missing" gives the message 3 times then Pixinsight opens. 1.8.8.2 does not have this error. Is there a way to fix this ? Thanks.........

Update ... PixInsight 1.8.8 installs and works just fine. After all updates version shows 1.8.8.2 and no missing dll error message. Research indicates that this should be provided by the install software. Could it possibly be left out of the version ?

Win 7 64 bit.
 

SdA

Member
Sep 3, 2017
11
0
Win 7  x64

Problem solved. I found  api-ms-win-core-libraryloader-l1-2-0.dll (32-Bit)    and copied it to PixInsight Bin.
 

SdA

Member
Sep 3, 2017
11
0
<* link removed *>

<* link removed *>

EDITED BY THE FORUM ADMINISTRATOR

Links removed because they pointed to unverified sources providing copies of Windows system files. Be aware that system files can only be obtained securely from the original operating system provider (Microsoft Corporation in this case). Downloading them from other sources online is extremely dangerous because of the potential risk of acquiring malwares.
 

Juan Conejero

PixInsight Staff
Sep 2, 2004
8,636
645
58
Valencia, Spain
pixinsight.com
This problem has nothing to do with PixInsight. The file you are referring to is a system component that should be provided by any clean and reasonably updated Windows installation, at least since 2015.

Research indicates that this should be provided by the install software. Could it possibly be left out of the version ?
Not at all. As noted, this file is a system component, so it should be provided by your operating system. These critical components must be kept up-to-date and synchronized with the rest of the system, and this is the sole responsibility of the operating system.

Besides this, please note that Windows 7 and Windows 8 are not supported by current versions of PixInsight. The only Windows version supported by PixInsight is Windows 10.
 

jbadal

New member
Oct 15, 2017
2
0
I reviewed my PI update email re: PixInsight 1.8.8-3 Ripley Released .

If in this email, There had been an easily identifiable comment, that " NOTE- THIS RELEASE IS ONLY FOR WINDOWS 10 !"-

Would have saved me a few hours of trying to figure out why I couldn't download the release.











 
 


 





 


 
 


 



 


 



 


 
 


 





 

Poschinger

New member
Nov 11, 2011
1
0
I found this. Perhaps you can find out that it perhaps will be possible to use win7 for a longer time!

https://social.msdn.microsoft.com/Forums/de-DE/c6a48da4-f6d6-4d8b-af60-b2798d7238ba/systemfehler-quotapimswincoresynchl120dllquot-fehlt?forum=visualbasicde

Konstantin
 

Andres.Pozo

PTeam Member
Jul 7, 2008
945
6
Madrid
Poschinger said:
I found this. Perhaps you can find out that it perhaps will be possible to use win7 for a longer time!

https://social.msdn.microsoft.com/Forums/de-DE/c6a48da4-f6d6-4d8b-af60-b2798d7238ba/systemfehler-quotapimswincoresynchl120dllquot-fehlt?forum=visualbasicde

Konstantin
If you think that that link is interesting, could you please translate it?