Author Topic: PixInsight is not binary compatible with modern FreeBSD (Redux)  (Read 683 times)

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Cross posting this here for (hopefully) better visibility, since it doesn't seem to be getting any responses on other boards. I see that the developers are online on the forum fairly often, so I presume they've read this post on the General board, as well as my private messages on the matter. I appreciate that there probably aren't many PixInsight users using FreeBSD, but we're out here! Any indication of whether or not this is on the roadmap to be fixed would be great, even if it is to tell me to stop wasting my time, and the development team's time with this issue, and use some other software.

Greetings,

I suppose this post is geared towards the PI development team (namely Juan). I check in to see, periodically, but there hasn't been a PI release for FreeBSD over two years now. I'm aware that there have been issues with Qt, amongst other libraries, for the FreeBSD build, as well as personal issues which have hindered development, but the current release is not binary compatible with recent FreeBSD (base system, ports) and is therefore unusable, unless one has frozen their system two years ago. Is it possible to even get an old version (even with old Qt) that's linked against a more recent FreeBSD libc etc? Is there a new version which will support FreeBSD in the works, or is support dead/dying?

Any input or insight on the matter from the development team or the community is appreciated.
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Re: PixInsight is not binary compatible with modern FreeBSD (Redux)
« Reply #1 on: 2018 September 03 23:58:54 »
Bump, again. I'm lighting candles in hope at this point...
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6582
    • View Profile
    • http://pixinsight.com/
Re: PixInsight is not binary compatible with modern FreeBSD (Redux)
« Reply #2 on: 2018 September 04 12:02:12 »
Hi Conor,

I am very sorry about this. Today I have spent almost the whole day trying to build Qt 5.9.x or 5.10.x on FreeBSD 12.0-CURRENT (TrueOS distro, up-to-date). I give up. Unless I am overlooking something important, it seems that no Qt 5.9 version or newer can be built on FreeBSD currently. 5.9 builds but we need QtWebEngine, which does not build. 5.10 does not build at all, the same with 5.11. Before Summer we had a Qt 5.9.4 port that seemed to work, but it has been replaced with a Qt 5.10.1 port recently, which does not build. This leaves me with no way to compile the core PixInsight 1.8.5 application on FreeBSD.

What can I do? Why cannot we have a working Qt 5.9 or newer version that builds without problems on FreeBSD, just as it can be built on Linux, macOS and Windows?
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Re: PixInsight is not binary compatible with modern FreeBSD (Redux)
« Reply #3 on: 2018 September 04 14:59:47 »
Hi Conor,

I am very sorry about this. Today I have spent almost the whole day trying to build Qt 5.9.x or 5.10.x on FreeBSD 12.0-CURRENT (TrueOS distro, up-to-date). I give up. Unless I am overlooking something important, it seems that no Qt 5.9 version or newer can be built on FreeBSD currently. 5.9 builds but we need QtWebEngine, which does not build. 5.10 does not build at all, the same with 5.11. Before Summer we had a Qt 5.9.4 port that seemed to work, but it has been replaced with a Qt 5.10.1 port recently, which does not build. This leaves me with no way to compile the core PixInsight 1.8.5 application on FreeBSD.

What can I do? Why cannot we have a working Qt 5.9 or newer version that builds without problems on FreeBSD, just as it can be built on Linux, macOS and Windows?

Hey Juan

Great to hear from you! I trust that all is well.

Yeah, the Qt project don't really care about BSD at all, which certainly is frustrating. I'm currently using FreeBSD 11.2-RELEASE (amd64), and the devel/qt5 port (at version 5.10.1) builds fine here. I've also built www/qt5-webkit separately here, including force building all of the dependencies, and it, too, builds okay. Can you clarify if it is that the ports aren't building there, or PixInsight isn't building with those port versions? Perhaps this is a problem with the TrueOS overlays? I know they've caused all sorts of problems in the past, when vanilla FreeBSD has been fine.

I'm running FreeBSD 12.0-CURRENT on an arm64 (note ARM, not AMD), and had some success there (the port build is taking a while...) so I'm not sure that FreeBSD 12.0-CURRENT llvm/clang or BSD libc etc would be the problem here. The FreeBSD portsmon site might shed some insights if things don't build with 12.0-CURRENT.

Would it make sense to support 11.2-RELEASE, or any RELEASE, as something more stable and longer lived than 12.0-CURRENT? It feels like it'd be less work, and would leave the painful Qt port maintenance to the FreeBSD ports maintainers. What do you think? More importantly, what can I do to help?
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Re: PixInsight is not binary compatible with modern FreeBSD (Redux)
« Reply #4 on: 2018 September 11 04:50:25 »
Just an update: I've just bumped my Qt installation to 5.11.1, built from ports, on FreeBSD 11.2-RELEASE. All components have built without error.
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6582
    • View Profile
    • http://pixinsight.com/
Re: PixInsight is not binary compatible with modern FreeBSD (Redux)
« Reply #5 on: 2018 September 11 05:48:53 »
Hi Conor,

Have ports been updated to Qt 5.11.1? If yes and it builds, that's very good news. However, we need QtWebEngine (not QtWebKit, which is now obsolete) to build the core application, which is the most difficult part. If it can also be built, then we'll have a working version of PixInsight. Fingers crossed!
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Re: PixInsight is not binary compatible with modern FreeBSD (Redux)
« Reply #6 on: 2018 September 11 06:59:31 »
Hey Juan

Yeah, most of the qt5 ports bumped to 5.11.1 on the 9th of September. However, I've just noticed that www/qt5-webengine has not. It appears to still be frozen at 5.9.5. I suspect, then, that you're very correct about its newer release not building on FreeBSD. I'll see if this port bumps in the next few days and ping the port maintainers on EFNet and keep you posted.

Fingers crossed, indeed!
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Hey Juan

Good news! The FreeBSD www/qt5-webengine port has finally been bumped to 5.12.1. Does that unblock a new FreeBSD PixInsight release?
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD

Offline Juan Conejero

  • PTeam Member
  • PixInsight Jedi Grand Master
  • ********
  • Posts: 6582
    • View Profile
    • http://pixinsight.com/
Hi Conor,

Yes, very good news, hopefully. If I can build a complete Qt 5.12 version with QtWebEngine, then the next release will include a FreeBSD version. I am trying to configure a working Trident desktop on a VMware virtual machine right now (a frustratingly complicated and time consuming task, BTW). Let's see, fingers crossed again!
Juan Conejero
PixInsight Development Team
http://pixinsight.com/

Offline Conor

  • Member
  • *
  • Posts: 73
    • View Profile
Excellent! All being well, I'm definitely looking forward to being able to use PixInsight again!

Aside; I've just become aware of Trident. As you know, I'm a vanilla FreeBSD guy, but I'm always interested to see what derivative projects are doing. Bear in mind that, if you're building qt5-webengine from ports, I had had to follow the note from UPDATING in the ports tree which suggests that you may have to uninstall the port before building/installing it again if you're not using poudriere (I use portmaster).

Let me know if I can be of any help!
Takahashi FSQ 106 EDX III w/ QE Reducer
William Optics 110FLT Apo Triplet
William Optics Megrez 72 Apo Doublet
iOptron CEM60
QSI 583ws & 3nm Ha/OIII/SII filters
SBIG ST-i
Trying to use PixInsight on FreeBSD